Extraire Valeurs uniques d'un tableau avec leurs sommes Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
k
koubor
Nouveau venu
Nouveau venu
Messages : 4
Inscrit le : 20 mai 2016
Version d'Excel : 2013

Message par koubor » 20 mai 2016, 09:39

Bonjour,

J'ai 2 colonnes :
A B
Jean 15
Pierre 20
Marc 10
Pierre 30
Jean 5
Marc 10

J'aimerai trouver une formule qui me donne en colonne C et D les valeurs unique de A et la somme correspondant aux valeurs dans B :
C D
Jean 20
Pierre 50
Marc 15

Je suis passé par des formules matricielles et des nb.si mais je ne pense pas avoir l’expérience pour bien les utiliser.
Est ce que vous pourriez me donner un exemple de formule ?

(En bonus : je réfléchi à trier les colonnes C et D par ordre décroissant des valeurs en D ^^ si vous pouvez m'eguiller se serait top)
Avatar du membre
Raja
Passionné d'Excel
Passionné d'Excel
Messages : 5'208
Appréciations reçues : 14
Inscrit le : 3 février 2008
Version d'Excel : 2010 à 2016 FR et 2010 EN

Message par Raja » 20 mai 2016, 09:49

Bonjour,
somme.si.xlsx
(11.66 Kio) Téléchargé 47 fois
Cdlt,
Raja
Avatar du membre
M12
Membre impliqué
Membre impliqué
Messages : 2'874
Appréciations reçues : 99
Inscrit le : 3 juillet 2015
Version d'Excel : 2013

Message par M12 » 20 mai 2016, 10:05

Bonjour koubor, Raja

Un test en VBA (cf J Boisgontier)
koubor.xlsm
(20.85 Kio) Téléchargé 67 fois
Merci de clôturer le fil en cliquant sur le bouton V vert du post à coté du bouton EDITER si problème résolu

Je ne répond pas au message privé
k
koubor
Nouveau venu
Nouveau venu
Messages : 4
Inscrit le : 20 mai 2016
Version d'Excel : 2013

Message par koubor » 20 mai 2016, 11:44

Bonjour,
Merci pour la vitesse de vos réponses. L'idée de la macro est vraiment top et simple, le soucis c'est qu'il va y avoir beaucoup beaucoup de traitement du genre et rajouter une action nécessitant un clic en plus risque de faire perdre du temps.
Merci Raja pour l'idée du tableau croisée dynamique mais là encore cela nécessitera des actions en plus (pour une 30 aines de fichiers à gérer, relancer à a chaque fois un tableau dynamique va être long.

J'ai rajouté en pièce jointe la demande explicite.

Je cherche à trouver une formule qui quand je met à jour les colonnes A et B, automatiquement les valeurs en C se mettent à jour. Comme pour la colonne D avec la formule =SOMME.SI(A:A;C2;B:B) sachant que la liste des prenoms peux changer :
au lieux de Marc il pourra y avoir Jeremy à la prochaine mise à jour
Tri par valeurs uniques.xlsx
(13.67 Kio) Téléchargé 38 fois
k
koubor
Nouveau venu
Nouveau venu
Messages : 4
Inscrit le : 20 mai 2016
Version d'Excel : 2013

Message par koubor » 20 mai 2016, 12:21

Je suis passé par une formule matricielle (voir pièce jointe)
J'aimerai savoir ce que vous en pensez, ça à l'air de fonctionner
Tri par valeurs uniques V2.xlsx
(19.96 Kio) Téléchargé 75 fois
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message