Formule SI OU trop compliquée pour moi

Bonjour à tous,

Petite presentation rapide

Je suis salarié et j'ai pour "mission" de créer une application facilitant la vie ...

Je suis bloqué sur une formule et je ne sais pas par quel bout la prendre

J'en appel à l'aide car je cale...

exemple:

colonne A = montants

colonne B = ecarts

Dans la colonne B j'aimerai integrer:

Si montants<5000€ alors ecarts=(100000/montants)

Ou Si 5000€<montants<40000€ alors ecarts= (500+(montantsx0,1)) / (montantsx100)

Ou Si montants>40000€ alors ecarts= (2500+(montantsx0,05)) / (montantsx100)

Je ne saias pas si c'est très clair

Je vous joint un fichier pour exemple

Merciiii

22test.xls (16.50 Ko)

Bonjour,

A tester en B2 :

=SI(A2<5000;10000/A2;SI(5000<A2<40000;((500+A2*0,1)/(A2*100));(2500+A2*0,05)/(A2*100)))

Il faudra voir ce que tu veux faire avec les bornes ... au besoin ajouter un ou l'autre signe =

Cordialment,

Vbabeginner

Super

Par contre cela ne marche pas pour les montants entre l'intervalle

Une idée?

bipbip8086 a écrit :

Super

Par contre cela ne marche pas pour les montants entre l'intervalle

Une idée?

Bonjour,

Quand tu parles de l'intervalle, tu parles de 5000<A2<40000 ?

Bonjour papysg,

Oui c'est bien ça, en mettant :

SI(5000<A2<40000;((500+A2*0,1)/(A2*100)))

le resultat est eronnée

Re,

Teste ceci :

=Si(A2<5000;10000/A2;Si(ET((A2>5000);(A2<40000));((500+A2*0,1)/(A2*100));(2500+A2*0,05)/(A2*100)))

Cordialement,

Vbabeginner

Bonjour, Salut à tous,

Pour comprendre mieux ton attente, il est intéressant de savoir le résultat que tu attends dans le fichier mis à disposition.

Merci Vbabeginner, c'est exactement ce que je recherchai

Parfait alors !

Bonne continuation !

Rechercher des sujets similaires à "formule trop compliquee moi"