Macro Calcul durée entre 2 dates selon plage horaire et +

Y compris Power BI, Power Query et toute autre question en lien avec Excel
k
koodbook
Jeune membre
Jeune membre
Messages : 44
Inscrit le : 11 février 2014
Version d'Excel : 2016

Message par koodbook » 3 mai 2016, 11:44

Bonjour le forum,

Me voilà confronter à un problème de taille. Aujourd'hui je calcule tout à la main et cela me prend énormément de temps. :cry:

Je dois calculer les mesures suivantes:
  • Durée d’indisponibilité en minutes
    Durée d'indisponibilité en heures:minutes
    Le taux de disponibilité
Cela en fonction:
  • de la date de début et de la date de fin de l'indisponibilité
    des classes, chaque classe à des horaires de services différents
    des jours ouvrés (selon les classes)
J'ai vraiment besoin d'aide... (voir fichier en pj)

Quelqu'un pourrait-il m'aider?

Je vous remercie pour votre aide précieuse.
Exemple.xlsx
(19.67 Kio) Téléchargé 87 fois
Avatar du membre
AMIR
Membre dévoué
Membre dévoué
Messages : 748
Appréciations reçues : 7
Inscrit le : 19 janvier 2015
Version d'Excel : 2007

Message par AMIR » 3 mai 2016, 13:22

bonjour

regarder avec ca :
Heure de début Heure de fin 
 A2 = 9/6/2007 10:35 b2 = 9/6/2007 15:30 

=TEXTE(B2-A2,"h") Heures entre deux heures (4) 
=TEXTE(B2-A2,"h:mm") Heures et minutes entre deux heures (4:55) 
=TEXTE(B2-A2,"h:mm:ss") Heures, minutes et secondes entre deux heures (4:55:00)
k
koodbook
Jeune membre
Jeune membre
Messages : 44
Inscrit le : 11 février 2014
Version d'Excel : 2016

Message par koodbook » 3 mai 2016, 14:02

Bonjour Amir,

Je te remercie pour ton retour mais cela ne m'aide pas trop :cry: ...
J'aimerais que ce soit un macro qui me calcule cela de manière automatique lorsque je saisi la date de début, la date de fin et la classe....
k
koodbook
Jeune membre
Jeune membre
Messages : 44
Inscrit le : 11 février 2014
Version d'Excel : 2016

Message par koodbook » 1 juin 2016, 13:19

Bonjour à tous,

UP de mon post.
Personne pour m'aider :( ?
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message