Fonction rechercheV trop lourde, alternative VBA

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Avatar du membre
R@chid
Membre impliqué
Membre impliqué
Messages : 2'665
Appréciations reçues : 24
Inscrit le : 14 novembre 2012
Version d'Excel : 2016 FR

Message par R@chid » 19 avril 2016, 20:05

Re,
en O13 :
=SIERREUR(RECHERCHEV(STXT(B13;5;9);INDIRECT("'selecom"&EQUIV(VRAI;NB.SI(INDIRECT("'selecom"&LIGNE($1:$24)&"'!B7:B350");STXT(B13;5;9))>0;0)&"'!B7:F350");5;FAUX);"")
@ valider par Ctrl+Shift+Enter
@ tirer vers le bas
c'est pas plus rapide mais plus courte.

Si les codes ne sont pas en double sur plusieurs onglets on peut faire avec SOMMEPROD(SOMME.SI()) en 3D.

avec des basses de données énormes une fonction personnalisé sera plus rapide et plus pertinente.



@ + +
"Donnez moi un point d'appui et je soulèverai le monde"
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message