Par tranche de 30 minutes

Y compris Power BI, Power Query et toute autre question en lien avec Excel
M
MaxwellCosta
Membre habitué
Membre habitué
Messages : 146
Inscrit le : 6 septembre 2015
Version d'Excel : 2010

Message par MaxwellCosta » 9 avril 2016, 17:35

Bonjour à tous,

En K2 j'ai des données avec un format du type 00:00:35 ( qui sont en fait des horaires.

Si en K2 la donnée commence par "00:0" alors afficher en L2 la valeur "00h00-00h29" et si en k2 la donnée commence par "00:30" alors afficher en L2 la valeur "00h30-01h00" ainsi de suite jusqu'aux K2 qui commencerai par "23:3" pour afficher en L2 la valeur 23h30-24h00

J'ai bien la formule par tranche horaire qui dit

=SI(K2="";"";TEXTE(HEURE(K2);"00")&"h-"&TEXTE(HEURE(K2)+1;"00")&"h")

mais je voudrai la transformer par tranche de 30 minutes et je ne sais pas comment faire.

Merci pour votre aide à tous
Max
M
MFerrand
Fanatique d'Excel
Fanatique d'Excel
Messages : 17'178
Appréciations reçues : 446
Inscrit le : 20 juillet 2015
Version d'Excel : 2010 FR

Message par MFerrand » 9 avril 2016, 21:21

Bonjour,
=TEXTE(ENT(K2*48)/48;"hh""h""mm")&"-"&TEXTE(ENT(K2*48)/48+29/1440;"hh""h""mm")
Tu remmettras la condition...

Cordialement.
M
MaxwellCosta
Membre habitué
Membre habitué
Messages : 146
Inscrit le : 6 septembre 2015
Version d'Excel : 2010

Message par MaxwellCosta » 9 avril 2016, 21:50

Merci beaucoup

:btres:
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message