Fonction SI.CONCLUSIONS

Y compris Power BI, Power Query et toute autre question en lien avec Excel
s
simon0669
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 8 avril 2016
Version d'Excel : 2013 pro

Message par simon0669 » 8 avril 2016, 14:19

Bonjour a tous,

Voilà je fais face à un problème, nous avons créé un fichier sous Excel 2016, en utilisant la fonction SI.CONCLUSION, apparemment cette fonction n'exister pas sur les versions d’Excel 2013.

Malheureusement, les personnes avec qui l'on travaille utilisent la version 2013. Nous avons donc changé la fonction SI.CONCLUSION pour utiliser la fonction SI.

La fonction étant une fonction SI avec plusieurs termes (10 au total ).

Ci-dessous la version SI que nous avons crée qui fonctionnent, par contre nous somme limité a 8 imbrications , contrairement a la fonction SI.CONCLUSION qui nous permettez plus .....

=SI(B17<13;1;SI(B17<25;2;SI(B17<37;3;SI(B17<49;4;SI(B17<61;5;SI(B17<73;6;SI(B17<85;7;SI(B17<97;8))))))))

Nous sommes limités à huit imbrications, au-dessus de 8, la formule n'est plus valide.

Comment faire pour ajouter plus d'imbrications sans utiliser la fonction SI.CONCLUSION ?

Je vous remercie pour l'aide apporter.

Bien cordialement,

Simon
Avatar du membre
OOoiste
Membre impliqué
Membre impliqué
Messages : 1'600
Appréciations reçues : 20
Inscrit le : 1 octobre 2009
Version d'Excel : office 365

Message par OOoiste » 8 avril 2016, 14:25

Bonjour,

Un simple EQUIV ou une table de correspondance en utilisant RECHERCHEV remplace avantageusement un succession de SI.

Exemple :

=EQUIV(B17;[0;13;25;37;49;61;73;95;97})

ou encore une simple formule mathématique :

=1+ENT((B17+1)/12)

A+
Avatar du membre
R@chid
Membre impliqué
Membre impliqué
Messages : 2'756
Appréciations reçues : 35
Inscrit le : 14 novembre 2012
Version d'Excel : 2019 FR

Message par R@chid » 8 avril 2016, 14:30

Bonjour
:bv:
Salut OOoiste,
je pense que c'est plutôt :
=1+ENT((B17[surligner=#FF0000]-1[/surligner])/12)

@ + +
"Donnez moi un point d'appui et je soulèverai le monde"
Avatar du membre
Gaz0line
Membre dévoué
Membre dévoué
Messages : 566
Appréciations reçues : 3
Inscrit le : 28 juillet 2012
Version d'Excel : 2010 FR, 2013 FR
Téléchargements : Mes applications

Message par Gaz0line » 8 avril 2016, 14:34

C'est une limitation de 2013 ?
Parce que sur 2010 ça fontionne (je n'ai pas de 2013 sous la main pour tester pour le moment !)
Je viens de tester sur 2010 et ça fonctionne sans problème avec + de 8 imbrications...

=SI(A1<13;1;SI(A1<25;2;SI(A1<37;3;SI(A1<49;4;SI(A1<61;5;SI(A1<73;6;SI(A1<85;7;SI(A1<97;8;
SI(A1<100;9;SI(A1<200;10;SI(A1<300;11)))))))))))
“La politesse coûte peu et achète tout.” - Montaigne
Pense à cliquer sur le bouton résolu si ton problème est résolu !
s
simon0669
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 8 avril 2016
Version d'Excel : 2013 pro

Message par simon0669 » 8 avril 2016, 14:36

Impeccable je vous remercie pour la réactivité, j'envoie ça à Céline, et je vient confirmer que tout fonctionne parfaitement.

Gazoline ici sous office pro 2013 message d'erreur car trop d'imbrication.

à toute :)
Avatar du membre
OOoiste
Membre impliqué
Membre impliqué
Messages : 1'600
Appréciations reçues : 20
Inscrit le : 1 octobre 2009
Version d'Excel : office 365

Message par OOoiste » 8 avril 2016, 14:40

R@chid a écrit :Bonjour
:bv:
Salut OOoiste,
je pense que c'est plutôt :
=1+ENT((B17[surligner=#FF0000]-1[/surligner])/12)

@ + +
Oui, c'est mieux en enlevant 1.
Bien vu
Avatar du membre
Gaz0line
Membre dévoué
Membre dévoué
Messages : 566
Appréciations reçues : 3
Inscrit le : 28 juillet 2012
Version d'Excel : 2010 FR, 2013 FR
Téléchargements : Mes applications

Message par Gaz0line » 8 avril 2016, 14:47

OOoiste a écrit : ou encore une simple formule mathématique :
=1+ENT((B17+1)/12)
R@chid a écrit : je pense que c'est plutôt :
=1+ENT((B17[surligner=#FF0000]-1[/surligner])/12)
Sans déconner, vous êtes vraiment impressionnants messieurs ! :D
“La politesse coûte peu et achète tout.” - Montaigne
Pense à cliquer sur le bouton résolu si ton problème est résolu !
s
simon0669
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 8 avril 2016
Version d'Excel : 2013 pro

Message par simon0669 » 8 avril 2016, 15:12

Tous marche NICKEL nous avons maintenant des feuilles de devis ultra personnalisé !!! TIP TOP TOP :) :) :)

Nous utilisons donc simplement la formule mathématique.

MERCI à tous
Avatar du membre
R@chid
Membre impliqué
Membre impliqué
Messages : 2'756
Appréciations reçues : 35
Inscrit le : 14 novembre 2012
Version d'Excel : 2019 FR

Message par R@chid » 8 avril 2016, 16:05

Re,
on peut le faire aussi avec :
=PLAFOND(B17/12;1)
reste un cas particulier dont on n'a pas parlée, le 0 est inférieur à 13 et toutes nos formules renvoient 0 par contre avec la tienne ça renvoie 1, donc à toi de nous dire en cas de 0 que souhaites-tu obtenir ?
Si tu souhaites obtenir 1 comme c'est le cas avec ta formule :
=MAX(1+ENT((B17-1)/12);1)
ou
=MAX(PLAFOND(B17/12;1);1)



@ + +
"Donnez moi un point d'appui et je soulèverai le monde"
P
Peuwi
Membre fidèle
Membre fidèle
Messages : 186
Appréciation reçue : 1
Inscrit le : 5 janvier 2016
Version d'Excel : 2010

Message par Peuwi » 8 avril 2016, 16:46

Bonjour,

sinon, pour répondre à la question initiale, et bien que ce soit parfaitement atroce, il est possible d'imbriquer davantage de fonction si en équilibrant la charge, ici avec 3 imbrications :
si(B4; si(B2 ; si(B1 ; C1;C2) ; si(B3 ; C3;C4) ) ; si(B6 ; si(B5 ; C5;C6) ; si(B7 ; C7;C8) )
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message