Liste déroulante avec saisie semi automatique

Y compris Power BI, Power Query et toute autre question en lien avec Excel
j
julie0803
Membre habitué
Membre habitué
Messages : 63
Inscrit le : 29 janvier 2016
Version d'Excel : XLSX 2007 FR

Message par julie0803 » 1 mars 2016, 15:17

Bonjour,

je recherche comment effectuer une liste déroulante semi automatique à partir d'un fichier client.

Nous avons nommé la première cellule du fichier client,
ensuite nous avons nommé toute la colonne,
ensuite nous avons réalisé une nouvelle formule appelée l_nom (=DECALER(d_nom;0;0;NBVAL(col)-1;1)),
ensuite nous avons été dans les validations de données et on a mis en source N_nom.
Mais sans succès!

Est-il possible de le réaliser avec une fonction ?

Merci
Avatar du membre
Steelson
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'611
Appréciations reçues : 672
Inscrit le : 13 octobre 2014
Version d'Excel : 2013 FR

Message par Steelson » 1 mars 2016, 16:07

=DECALER(d_nom;1;;NBCAR(col)-1)

O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸ O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸
PI = 3.14159 26535 89793 23846 26433 83279 50288 41971 69399 37510 58209 74944 59230 78164 06286 20899 86280

( ͡• ͜ʖ ͡• )
j
julie0803
Membre habitué
Membre habitué
Messages : 63
Inscrit le : 29 janvier 2016
Version d'Excel : XLSX 2007 FR

Message par julie0803 » 11 mars 2016, 11:36

Bonjour,

Merci de votre réponse, mais nous n'arrivons toujours pas à réaliser cette saisie semi automatique.
Nous avons juste les premiers noms du fichier client.

je vous envoi notre dossier pour vous puissiez voir notre travail et ainsi constater les problèmes rencontrés.
Planning-liste-déroulante-semi-automatique.xlsm
(37.31 Kio) Téléchargé 265 fois
Merci.

Julie.s
Avatar du membre
Steelson
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'611
Appréciations reçues : 672
Inscrit le : 13 octobre 2014
Version d'Excel : 2013 FR

Message par Steelson » 11 mars 2016, 13:12

NBVAL et non NBCAR
=DECALER(d_nom;1;0;NBVAL(col)-1)
je vous avais induit en erreur
d'où l'importance de poster un fichier tout de suite ...

O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸ O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸
PI = 3.14159 26535 89793 23846 26433 83279 50288 41971 69399 37510 58209 74944 59230 78164 06286 20899 86280

( ͡• ͜ʖ ͡• )
j
julie0803
Membre habitué
Membre habitué
Messages : 63
Inscrit le : 29 janvier 2016
Version d'Excel : XLSX 2007 FR

Message par julie0803 » 11 mars 2016, 13:31

Merci de votre réponse, nous avons testé votre formule, nous avons bien la totalité des noms mais il n'y a pas de liste semi automatique qui s'affiche.

Je vous joint notre résultat:
Suivi de trésorerie avec-filtre-avancée.xlsm
(52.86 Kio) Téléchargé 127 fois

Merci.

Julie.s
Avatar du membre
Steelson
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'611
Appréciations reçues : 672
Inscrit le : 13 octobre 2014
Version d'Excel : 2013 FR

Message par Steelson » 11 mars 2016, 13:50

Julie,

on est bien sur le même fichier ?

Pour le moment, ma seule intervention a été de corriger ceci :
julie0803 a écrit : l_nom (=DECALER(d_nom;0;0;NBVAL(col)-1;1))
Capture d’écran (25).png
Capture d’écran (25).png (14.99 Kio) Vu 2901 fois
Planning-liste-déroulante-semi-automatique.xlsm
(35.71 Kio) Téléchargé 100 fois

O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸ O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸
PI = 3.14159 26535 89793 23846 26433 83279 50288 41971 69399 37510 58209 74944 59230 78164 06286 20899 86280

( ͡• ͜ʖ ͡• )
j
julie0803
Membre habitué
Membre habitué
Messages : 63
Inscrit le : 29 janvier 2016
Version d'Excel : XLSX 2007 FR

Message par julie0803 » 11 mars 2016, 14:06

Oui veuillez m'excuser je n'est pas envoyé le bon fichier.

Oui cela correspond bien à une liste déroulante, mais j'aurais aimé que lorsque l'on tape une lettre par exemple "a" tout les noms commençant par "a" apparaisse dans la liste déroulante.

Merci.
Avatar du membre
Steelson
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'611
Appréciations reçues : 672
Inscrit le : 13 octobre 2014
Version d'Excel : 2013 FR

Message par Steelson » 11 mars 2016, 16:52

Okay
C'est tout autre chose ...
Voici :
Planning-liste-déroulante-semi-automatique.xlsm
(46.44 Kio) Téléchargé 541 fois

O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸ O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸
PI = 3.14159 26535 89793 23846 26433 83279 50288 41971 69399 37510 58209 74944 59230 78164 06286 20899 86280

( ͡• ͜ʖ ͡• )
l
lareran
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 25 mai 2016
Version d'Excel : 2013

Message par lareran » 25 mai 2016, 16:07

Bonjour,

La fonction d'après ce que vous dites devrait ressembler à peu près à cela :

Ex:
Sur la feuille 2 vous avez votre liste de noms sur la matrice Feuil2!A1:A100

Sur la feuille1, nous mettons en place la liste déroulante avec saisie semi automatique sur la cellule B1

Résultat : =SI(B1<>"";DECALER(Feuil2!$A$1;EQUIV(B1&"*";Feuil2!$A$1:$A$100;1);0;NB.SI(Feuil2!$A$1:$A$100;B1&"*");"")

Voilà je penses que cela correspond à ce que vous voulez avec un peu de retard sur le message initial
N
Nanisa
Nouveau venu
Nouveau venu
Messages : 1
Inscrit le : 18 janvier 2017
Version d'Excel : 2013 FR

Message par Nanisa » 18 janvier 2017, 19:39

lareran a écrit :Bonjour,

La fonction d'après ce que vous dites devrait ressembler à peu près à cela :

Ex:
Sur la feuille 2 vous avez votre liste de noms sur la matrice Feuil2!A1:A100

Sur la feuille1, nous mettons en place la liste déroulante avec saisie semi automatique sur la cellule B1

Résultat : =SI(B1<>"";DECALER(Feuil2!$A$1;EQUIV(B1&"*";Feuil2!$A$1:$A$100;1);0;NB.SI(Feuil2!$A$1:$A$100;B1&"*");"")

Voilà je penses que cela correspond à ce que vous voulez avec un peu de retard sur le message initial
Bonjour ::)
J'aurais besoin d'utiliser ce type de formule, mais la colonne de référence contient un résultat de type : = A38 & " " & C38
Est-ce que ça explique pourquoi je n'y arrive pas ?
Merci d'avance
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message