Formule conditionnelle

Y compris Power BI, Power Query et toute autre question en lien avec Excel
l
lhinsky
Jeune membre
Jeune membre
Messages : 11
Inscrit le : 24 février 2016
Version d'Excel : 2010 FR

Message par lhinsky » 25 février 2016, 10:20

Bonjour, après plusieurs essais je ne trouve pas de solution à mon problème. J'aimerais traiter cette formule dans excel :

"Si la cellule A1 contient le mot "Compteur" alors
la cellule A3 affiche le mot "oui".

Si la cellule A1 ne contient pas le mot "Compteur" alors
la cellule A3 affiche le mot "non".

Si la cellule A1 ne contient rien alors
la cellule A3 n'affiche rien."

Merci, bonne journée.
V
VBABEGINNER
Membre dévoué
Membre dévoué
Messages : 728
Inscrit le : 5 novembre 2014
Version d'Excel : 2010

Message par VBABEGINNER » 25 février 2016, 10:39

Bonjour,

A tester en A3 :
=SIERREUR(SI(A1="";"";SI(CHERCHE("compteur";A1;1)>0;"oui";"non"));"non")

Cordialement,


Vbabeginner
l
lhinsky
Jeune membre
Jeune membre
Messages : 11
Inscrit le : 24 février 2016
Version d'Excel : 2010 FR

Message par lhinsky » 25 février 2016, 11:27

Merci pour votre réponse. J'ai oublié de préciser que dans ma cellule A1 j'utilise une autre formule.
Du coup, quand ma cellule A1 est vide (en apparence), la formule elle, est toujours présente et donc ma cellule A3 affiche quand même "non".
V
VBABEGINNER
Membre dévoué
Membre dévoué
Messages : 728
Inscrit le : 5 novembre 2014
Version d'Excel : 2010

Message par VBABEGINNER » 25 février 2016, 11:39

Bonjour,

En effet, ce n'est pas un detail !

Alors à tester :
=SIERREUR(SI((NB.SI(A1;"><"))=0;"";SI(CHERCHE("compteur";A1;1)>0;"oui";"non"));"non")
Cordialement,


Vbabeginner
l
lhinsky
Jeune membre
Jeune membre
Messages : 11
Inscrit le : 24 février 2016
Version d'Excel : 2010 FR

Message par lhinsky » 25 février 2016, 11:50

Merci de votre rapidité, vous m'avez fait gagner un temps précieux ! Bonne journée.
V
VBABEGINNER
Membre dévoué
Membre dévoué
Messages : 728
Inscrit le : 5 novembre 2014
Version d'Excel : 2010

Message par VBABEGINNER » 25 février 2016, 11:51

Re,

Avec plaisir !

Bonne journée,


Vbabeginner
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message