Condition imbriquée

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
f
flo5957
Jeune membre
Jeune membre
Messages : 31
Inscrit le : 23 juin 2014
Version d'Excel : 2007

Message par flo5957 » 12 février 2016, 14:56

J'ai trois cellules H, I, J.

La colonne J est la somme de la colonne H et I

Je voudrais mettre une condition sur la colonne J en fonction de la H ou J, et faire en sorte qui si une des deux colonnes est vide que la colonne J est égale à celle qui n'est pas vide, sinon elle est égale à la somme des deux.

J'ai écrit ceci :

=IF(OR(H1="",I1=""),I1,I1+H1)

Mais vous remarquerez que c'est pas exactement ce que je recherche puisque si une des deux colonnes est vide il va me reprendre la valeur de I1 alors que c'est peut-être celle de H1 qu'il faut reprendre. Il faut reprendre celle qui n'est pas vide.

Il faudrait aussi une condition que si les deux colonnes sont vides, il met zéro.
a
alfa9
Membre habitué
Membre habitué
Messages : 80
Appréciations reçues : 2
Inscrit le : 14 janvier 2016
Version d'Excel : 2010

Message par alfa9 » 12 février 2016, 15:13

Bonjour,
Si je comprends pas bien ce que tu veux faire;
il suffit d'écrire:
=Somme(I1+H1)
et tu obtiendra ce que tu souhaites.
Si i1 et h1 ne sont pas des nombres alors utiliser peut-être =concatener().
cordialement.
Avatar du membre
Steelson
Fanatique d'Excel
Fanatique d'Excel
Messages : 14'976
Appréciations reçues : 881
Inscrit le : 13 octobre 2014
Version d'Excel : 2013 FR
Téléchargements : Mes applications

Message par Steelson » 12 février 2016, 15:20

Je pense qu'en mettant simplement =I1+H1 cela doit répondre, ou bien je n'ai pas bien lu le sujet !
condition sur la colonne J en fonction de la H ou J
je comprends que c 'est fonction de H ou I

O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸ O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸
PI = 3.14159 26535 89793 23846 26433 83279 50288 41971 69399 37510 58209 74944 59230 78164 06286 20899 86280

( ͡• ͜ʖ ͡• )
f
flo5957
Jeune membre
Jeune membre
Messages : 31
Inscrit le : 23 juin 2014
Version d'Excel : 2007

Message par flo5957 » 12 février 2016, 16:45

Non mais si H ou I est vide, il y a une erreur pour la somme H+I, donc il faut écrire une condition.

Comme j'ai écrit il faut faire H+I que si les deux ne sont pas vide. Mais ma condition écrite n'est pas totalement juste.
Avatar du membre
Steelson
Fanatique d'Excel
Fanatique d'Excel
Messages : 14'976
Appréciations reçues : 881
Inscrit le : 13 octobre 2014
Version d'Excel : 2013 FR
Téléchargements : Mes applications

Message par Steelson » 12 février 2016, 18:02

Curieux, j'ai testé cela fonctionne quand la cellule est vide !
Mais, si celle-ci est égale à " " (espace), ce n'est plus la même chose si la même formule !

Je préconise alors ceci :
=SI(ESTNUM(I1);I1;0)+SI(ESTNUM(J1);J1;0)

O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸ O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸
PI = 3.14159 26535 89793 23846 26433 83279 50288 41971 69399 37510 58209 74944 59230 78164 06286 20899 86280

( ͡• ͜ʖ ͡• )
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message