NB.SI avec un ou ? Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
M
Munouchka
Membre habitué
Membre habitué
Messages : 136
Inscrit le : 26 février 2014
Version d'Excel : 2013

Message par Munouchka » 22 janvier 2016, 18:53

Bonsoir le forum

Je cherche à faire un NB.SI avec un OU mais je ne sais pas comment procéder.
J'aimerai faire NB.SI.ENS('T1 TARV'!H$12:H$3011;C13;'T1 TARV'!$L12:$L3011;"X*"OU"ABS*"))

Pour le moment j'ai juste trouver d'additionner comme ça =NB.SI.ENS('T1 TARV'!H$12:H$3011;C13;'T1 TARV'!$L12:$L3011;"X*"))+NB.SI.ENS('T1 TARV'!H$12:H$3011;C13;'T1 TARV'!$L12:$L3011;"ABS*"))

D'avance merci
Hélène
Avatar du membre
R@chid
Membre impliqué
Membre impliqué
Messages : 2'798
Appréciations reçues : 39
Inscrit le : 14 novembre 2012
Version d'Excel : 2019 FR

Message par R@chid » 22 janvier 2016, 19:02

Bonsoir,
serait-il possible de joindre un fichier exemple pour faire les tests ?

@ te relire
"Donnez moi un point d'appui et je soulèverai le monde"
M
Munouchka
Membre habitué
Membre habitué
Messages : 136
Inscrit le : 26 février 2014
Version d'Excel : 2013

Message par Munouchka » 22 janvier 2016, 19:17

Voilà un exemple.
ça ne reprend pas ma formule car dans mon premier message, j'avais mis la formule de mon fichier de travail, que je ne peux pas mettre en ligne mais j'ai reconstitué la même situation.
D'avance merci
Exemple 3.xlsx
(8.68 Kio) Téléchargé 13 fois
Avatar du membre
OOoiste
Membre impliqué
Membre impliqué
Messages : 1'602
Appréciations reçues : 22
Inscrit le : 1 octobre 2009
Version d'Excel : office 365

Message par OOoiste » 22 janvier 2016, 19:29

Bonsoir,
=SOMMEPROD(NB.SI.ENS(B6:B12;{"X"."ABS"};$F$6:$F$12;"A"))
A+
M
Munouchka
Membre habitué
Membre habitué
Messages : 136
Inscrit le : 26 février 2014
Version d'Excel : 2013

Message par Munouchka » 22 janvier 2016, 19:40

Merci OOoiste.
Je suis donc obligée de passer par un sommeprod. J'ai peur que ça alourdisse mon fichier.
Je vais peut être rester avec mon addition alors.
Merci beaucoup
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'658
Appréciations reçues : 237
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 23 janvier 2016, 18:16

bonjour
sommeprod n'alourddit rien ,ou si peu ;c'est une legende
cordialement
SOMMEPROD((B6:B12={"x"."abs"})*(F6:F12="a"))
c'est en cherchant qu'on trouve
M
Munouchka
Membre habitué
Membre habitué
Messages : 136
Inscrit le : 26 février 2014
Version d'Excel : 2013

Message par Munouchka » 23 janvier 2016, 18:26

Merci à vous deux.
Bonne soirée
Hélène
M
Munouchka
Membre habitué
Membre habitué
Messages : 136
Inscrit le : 26 février 2014
Version d'Excel : 2013

Message par Munouchka » 23 janvier 2016, 20:49

Bonsoir
J'essaye d'appliquer la formule de OOoiste mais j'ai un soucis, c'est que mon X peut être accompagné d'autre donné.
Donc j'essaye de mettre une * dans la formule en faisant =SOMMEPROD(NB.SI.ENS(B6:B12;{"X*"."ABS*"};$F$6:$F$12;"A")). ça marche parfaitement quand j'ai que X dans la cellule mais dès que j'ai d'autres lettres en plus du X, ça ne fonctionne plus.
Pouvez vous m'aider?
Avatar du membre
R@chid
Membre impliqué
Membre impliqué
Messages : 2'798
Appréciations reçues : 39
Inscrit le : 14 novembre 2012
Version d'Excel : 2019 FR

Message par R@chid » 23 janvier 2016, 20:53

Bonsoir,
faute de ton fichier joint qui n’était pas explicite.
merci de joindre un fichier qui élucide bien ta problématique.


@ + +
"Donnez moi un point d'appui et je soulèverai le monde"
Avatar du membre
oyobrans
Membre impliqué
Membre impliqué
Messages : 1'042
Appréciations reçues : 16
Inscrit le : 27 septembre 2013
Version d'Excel : 2016

Message par oyobrans » 23 janvier 2016, 20:54

Qu'est-ce que tu peux avoir comme possibilités par exemple ?
(J'ai vraiment du mal aujourd'hui)
[Salut R@chid]
Cordialement.

Aide-toi et le ciel t'aidera.
[ GIF animé de Dave Whyte ]
Répondre Sujet précédentSujet suivant