Texte en abscisse nuage de points Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
a
addesign
Jeune membre
Jeune membre
Messages : 13
Inscrit le : 9 juillet 2015
Version d'Excel : 2013

Message par addesign » 21 juillet 2015, 15:46

Bonjour à tous,

Etant toujours sur mon fichier sous excel 2013, je cherche une autre solution afin d'arriver à mes fins.
Pour éviter de jongler avec des valeurs sous forme de texte à insérer dans le graph, j'associe un nombre à chaque valeur (voir colonne B dans le fichier joint).

Mais lorsque je fais le graph en nuage de points : souci.
Je me retrouve au total avec 5 valeurs possibles d'abscisses (numéros de 1 à 5).
Seulement, une fois dans le graph, les valeurs se trient en function de l'ordre de la liste, et non pas en function de la valeur de l'abscisse.

Concrètement : la première valeur de la liste que je veux en abscisse se retrouvera sur l'abscisse x=1, meme si en réalité la valeur est 2. (voir fichier).

>>> Apparement, le souci vient du fait que j'utilise des fonctions SI dans les cellules, car quand je tape les nombres à la main le graph se "trie" correctement

Comment puis-je contourner ce probleme ?



[EDIT] : Je viens de regarder depuis chez moi, le problème venait tout simplement des guillemets ::B-
Donc premier point résolu, reste à obtenir le texte associé en abscisse et ce sera parfait !

Ensuite autre souci, une fois avec mes valeurs numériques en abscisse (donc les valeurs de 1 à 5), je souhaite les remplacer par des valeurs de texte en faisant clic droit sur l'axe / Mise en forme de l'axe / Nombre / Catégorie / Personnalisé.

Ensuite dans le code de format je saisis :

[=1]"Basse pression";[=2]"Gravité";[=3]"Lost foam";[=4]"Rotacast";[=5]"Autre";;
Seulement je n'arrive à changer que les 2 premières valeurs et remplacer 1 et 2 par "Basse pression" et "Gravité". Les 3 autres valeurs n'apparaissent après plus sur le graph.

Je suis à disposition si besoin d'éclaircissements

Si quelqu'un a une solution ca me serait très très utile.

Merci beaucoup
Cdlt
Classeur1.xlsx
(13.78 Kio) Téléchargé 114 fois
Avatar du membre
Efgé
Membre fidèle
Membre fidèle
Messages : 326
Appréciations reçues : 4
Inscrit le : 21 juin 2013
Version d'Excel : 2007

Message par Efgé » 22 juillet 2015, 15:19

Bonjour addesign

Il y a plusieurs problèmes.
Le premier:
Si tu écris en formule =SI(A2="Basse pression"; "1";.....
Tu rencvoi un texte et non chiffre. enlève les "" et tout vas mieux pour le placement de tes points =SI(A2="Basse pression"; 1;

Ensuite pour les textes.
Le format de" nombre personalisé est limité à trois possibilités, donc dans ton cas ça ne vas pas.

Pour contourner le problème, il faut créer une seconde série à 0, la mettre sur l'axe secondaire, et la transformer en Courbe.
Comme ça tu peux afficher les étiquettes des points en mettant la catégorie.

Regarde le fichier joint.

Cordialement
Classeur1.xlsx
(13.69 Kio) Téléchargé 345 fois
a
addesign
Jeune membre
Jeune membre
Messages : 13
Inscrit le : 9 juillet 2015
Version d'Excel : 2013

Message par addesign » 22 juillet 2015, 15:40

Merci beaucoup,

Pour les guillemets effectivement je m'étais rendu compte du souci.
En revanche j'avais bricolé pour avoir le texte en ordonnée, mais c'est plus propre en abscisse pour mon utilisation.

Cependant, pourrais-tu stp detailler la methode pour :
il faut créer une seconde série à 0, la mettre sur l'axe secondaire, et la transformer en Courbe.
Comme ça tu peux afficher les étiquettes des points en mettant la catégorie.
Car j'avais déjà tenté une série supplémentaire en voyant la solution sur le net, mais je n'arrivais pas à faire fonctionner
Et meme en regardant le fichier que tu as envoyé et en essayant de le refaire je dois louper une étape ..

En tout cas merci, ça fonctionne nickel pour mon fichier.
J'aimerais juste être en mesure de le refaire tout seul

Merci :wink:
Avatar du membre
Efgé
Membre fidèle
Membre fidèle
Messages : 326
Appréciations reçues : 4
Inscrit le : 21 juin 2013
Version d'Excel : 2007

Message par Efgé » 22 juillet 2015, 15:49

Re

Tu faits ton graphique nuage de point.
Ensuite tu ajoute une série (dans mon exemple tu prends les zéros (=Feuil1!$D$18:$D$24)
Tu vas avoir une seconde série.
Tu clic dessus et tu choisis Mettre en forme une série de données. Dans option des séries tu choisis Axe secondaire / Ok.
Ensuite tu reclic dessus et tu choisis Modifier le type de graphique / Courbe.

Tu vas avoir une ligne droite en bas du graph.
Tu retourne dans "selectionner des données". Là tu choisi pour l'axe horizontal la plage =Feuil1!$C$18:$C$24
Cette ligne va te servir à "porter" les étiquettes en affichant les Catégories.

Cordialement.
a
addesign
Jeune membre
Jeune membre
Messages : 13
Inscrit le : 9 juillet 2015
Version d'Excel : 2013

Message par addesign » 22 juillet 2015, 15:58

Nickel ça fonctionne
Merci beaucoup :)
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message