MFC

Y compris Power BI, Power Query et toute autre question en lien avec Excel
c
chtimili
Membre habitué
Membre habitué
Messages : 139
Inscrit le : 3 janvier 2015
Version d'Excel : 2010

Message par chtimili » 2 juillet 2015, 16:20

EXEMPLE.xlsx
(10.18 Kio) Téléchargé 9 fois
bonjour a tous

je cherche a mettre fond de cellulles en rouge quand d'autres cellules contiennent au moins les mots SALLE ; REPRO ; GT . ETC..... comme dans l'exemple ci joint. en A1 j'ai "16 SALLE PASTEUR" mais je ne veux faire une recherche que sur une partie du contenu

Merci

yvon
T
Timothe URVOY
Membre fidèle
Membre fidèle
Messages : 371
Inscrit le : 9 octobre 2014
Version d'Excel : Excel2010 & Excel2013

Message par Timothe URVOY » 2 juillet 2015, 16:37

Bonjour,
=SI(OU(NB.SI(A1;"*SALLE*");NB.SI(A1;"*REPRO*");NB.SI(A1;"*GT*"));1;0)
à mettre dans règle (de la Mise en Forme Conditionnelle), mettre format rouge et définir la plage (pour l'exemple j'ai pris (=$A$1:$A$13).
Je ne me souviens plus jusqu'à quel nombre de conditions une MFC fonctionne mais vu que tu peux en mettre plusieurs sa va le faire ^^.
Je ne sais pas qui t'a dis de te servir de ta tête pour résoudre les problèmes ... mais ça ne voulait surement pas dire "sers-t'en SUR l'ordinateur" !
R
Robinet
Membre fidèle
Membre fidèle
Messages : 202
Inscrit le : 4 juillet 2012
Version d'Excel : 2007

Message par Robinet » 2 juillet 2015, 16:43

Bonjour, ou pour fouiller plus la chaîne: =OU((STXT($A1;4;5))="SALLE";GAUCHE($A1;2)="GT";STXT($A1;4;5)="REPRO")

a+
c
chtimili
Membre habitué
Membre habitué
Messages : 139
Inscrit le : 3 janvier 2015
Version d'Excel : 2010

Message par chtimili » 5 juillet 2015, 07:28

Merci beaucoup pour votre aide

bon Dimanche

A+
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message
  • Décaler des MFC et MFC sur une partie du texte
    par takumi059 » 19 mai 2015, 15:29 » dans Excel - VBA
    11 Réponses
    845 Vues
    Dernier message par takumi059
    28 mai 2015, 10:53
  • Ajouter une MFC sur une MFC
    par Moé Kolisse » 8 septembre 2016, 00:52 » dans Excel - VBA
    10 Réponses
    293 Vues
    Dernier message par andrea73
    10 septembre 2016, 17:17
  • Mfc
    par cecile tf alu » 7 août 2018, 18:08 » dans Excel - VBA
    4 Réponses
    68 Vues
    Dernier message par cecile tf alu
    8 août 2018, 11:12
  • Mfc
    par winj344 » 25 septembre 2018, 08:32 » dans Excel - VBA
    6 Réponses
    44 Vues
    Dernier message par Pedro22
    25 septembre 2018, 15:53
  • Mfc
    par lio63 » 18 octobre 2018, 11:17 » dans Excel - VBA
    3 Réponses
    69 Vues
    Dernier message par Juice
    18 octobre 2018, 12:40
  • mfc
    par rantig » 9 mai 2016, 18:19 » dans Excel - VBA
    4 Réponses
    67 Vues
    Dernier message par rantig
    10 mai 2016, 14:04