Fonction Index + equiv + decaler Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
p
pascale64
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 2 avril 2015
Version d'Excel : 2010

Message par pascale64 » 2 avril 2015, 15:08

Bonjour a tous,

J'ai besoin du coup de main des experts excel. J'ai cherche mais en vain.

Voici mon fichier de travail.
Excel.xlsx
(13.26 Kio) Téléchargé 37 fois
Il s'agit d'affecter un coefficient de productivite dans un planning selon la duree de la tache.
Il faut bien sur que le debut de la tache se reporte sur le planning.

J'arrive a faire demarrer la tache dans la bonne colonne. Par exemple la premiere tache va demarrer en Avril 2016 grace a la fonction SI + ET.
Je souhaite ensuite me referrer au tableau donnant les ratios de productivite selon la duree de la tache.
J'arrive a determiner facilement la ligne par contre je galere a definir la colonne qui doit etre '1' lorsque la tache commence dans le planning, puis se decaler vers la droite de 1, lorsque j'etends ma formule.
J'ai indique en jaune fluo les donnees que je souhaiterai obtenir.

Merci par avance pour votre aide....


=IF(AND(F$4>=$B7,F$4<=$A7),INDEX($AH$401:$BD$415,MATCH($AF7,$AF$401:$AF$415,0),XXXXXXXXXX),"")
h
h2so4
Passionné d'Excel
Passionné d'Excel
Messages : 8'975
Appréciations reçues : 359
Inscrit le : 16 juin 2013
Version d'Excel : 365 UK Windows 10

Message par h2so4 » 2 avril 2015, 15:37

Bonjour,

proposition de formule à mettre en F7 et à tirer vers la droite et vers le bas.
=SI(OU(F$4<$C7;$C7>F$4);"";INDEX($E$18:$N$32;EQUIV($D7;$C$18:$C$32);EQUIV(ENT((F$4-$C7)/30)+1;$E$17:$N$17;0)))
ou
=IF(OR(F$4<$C7,$C7>F$4),"",INDEX($E$18:$N$32,MATCH($D7,$C$18:$C$32),MATCH(INT((F$4-$C7)/30)+1,$E$17:$N$17,0)))
Avatar du membre
Steelson
Fanatique d'Excel
Fanatique d'Excel
Messages : 13'469
Appréciations reçues : 748
Inscrit le : 13 octobre 2014
Version d'Excel : 2013 FR
Téléchargements : Mes applications

Message par Steelson » 2 avril 2015, 15:50

Wahou, bilingue !!

O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸ O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸
PI = 3.14159 26535 89793 23846 26433 83279 50288 41971 69399 37510 58209 74944 59230 78164 06286 20899 86280

( ͡• ͜ʖ ͡• )
p
pascale64
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 2 avril 2015
Version d'Excel : 2010

Message par pascale64 » 2 avril 2015, 16:15

Au top!! Merci beaucoup...!!
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message