Addition plage cellules selon critères autres cellules Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
s
stephhp
Nouveau venu
Nouveau venu
Messages : 5
Inscrit le : 12 février 2015
Version d'Excel : 2007FR

Message par stephhp » 12 février 2015, 11:19

Bonjour,

Je recherche la formule suivante :

Addition des nombres d'une plage de cellule en fonction de critères indiqués dans d'autres cellules.

Exemple : dans cellule A1 total des nombres indiqués dans les cellules B1:B10 si indiqué "TOTO" dans C1:C10
dans cellule A2 total des nombres indiqués dans les cellules B1:B10 si indique "TATA" dans C1:C10

Je vous remercie pour votre aide.
Stéphane
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'300
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 12 février 2015, 11:48

Bonjour le forum,

Peut-être ???
=SI(NB.SI(C1:C10;"TOTO")>0;SOMME(B1:B10);"")
ou :
=SI(NB.SI(C1:C10;"TOTO")>0;SOMME(B1:B10);"TATA")
s
stephhp
Nouveau venu
Nouveau venu
Messages : 5
Inscrit le : 12 février 2015
Version d'Excel : 2007FR

Message par stephhp » 12 février 2015, 19:23

Merci mais pas bon : le total des chiffres de la colonne est repris sans tenir compte du critère "TOTO"...

Je m'exprime peut être mal : il ne faut prendre en compte dans le calcul QUE les sommes de "TOTO".
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'300
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 12 février 2015, 20:02

Re,

A1 :
=SOMMEPROD(($C$1:$C$10="TOTO")*($B$1:$B$10))
A2 :
=SOMMEPROD(($C$1:$C$10="TATA")*($B$1:$B$10))
s
stephhp
Nouveau venu
Nouveau venu
Messages : 5
Inscrit le : 12 février 2015
Version d'Excel : 2007FR

Message par stephhp » 13 février 2015, 18:07

C'est parfait. Merci !
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message