Création planning Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
j
jeanninetarten
Nouveau venu
Nouveau venu
Messages : 4
Inscrit le : 7 décembre 2014
Version d'Excel : FR2007

Message par jeanninetarten » 7 décembre 2014, 14:37

Bonjour le forum, je suis nouveau !
Je sollicite votre aide car je me trouve dans l'incapacité d'effectuer une tâche.
Il faudrait que, dans le document joint, lorsque une case est colorée (uniquement pour trois couleurs, à savoir: vert, jaune et rouge), dans la case "heures prises" soit mis le nombre d'heures prises de la journée (une case colorée rouge, jaune ou vert prend 2 heures).

J'espère avoir été assez clair et compréhensif :)
Dans le fichier des exemples sont mis pour plus de compréhension.
Merci d'avance
Planing.xlsx
(26.31 Kio) Téléchargé 32 fois
Avatar du membre
LouReeD
Contributeur
Contributeur
Messages : 7'086
Appréciations reçues : 370
Inscrit le : 14 octobre 2014
Version d'Excel : 2013 FR, 2016 FR
Contact :
Téléchargements : Mes applications

Message par LouReeD » 7 décembre 2014, 14:51

Bonjour,

En regardant vite fait, le plus simple serait une correspondance valeur couleur :
tapez un V et la case devient verte
tapez un J et la case devient jaune
tapez un R et la case devient rouge

Tout ceci géré par les mise en forme conditionnelle, qui mettrait la couleur de la police dans la même teinte afin de ne pas voir le texte.

Ensuite un simple nb.si(plage;critère) pour faire l'addition et comptabiliser le nombre d'heure : =NB.SI(B3:F14;"V")*2+NB.SI(B3:F14;"J")*2+NB.SI(B3:F14;"R")*2

@ bientôt

LouReedD

Nota : si V, J et R donne deux heures le NB.SI(plage;critère) se résume à <>"" =NB.SI(B3:F14;<>"")
Ca marche ?
Quelques règles à lire ICI ;;)
______________________________________________________Vous pouvez allez faire un tour sur : Index de "Mes applications" ;;)
A
Amadéus
Fanatique d'Excel
Fanatique d'Excel
Messages : 17'620
Appréciations reçues : 79
Inscrit le : 7 mai 2006
Version d'Excel : Office Excel 2003 FR et 2013FR

Message par Amadéus » 7 décembre 2014, 14:52

Bonjour
tu nous dis qu'une "case" colorée prend 2h
et tu nous mets en exemple
Pour lundi 6 cases colorées (en principe selon ton énoncé 12h) et tu veux 10h comme résultat?
Pour mardi, même problème, 4 cases colorées (Soit 4X2=8h) et là, tu veux 4 h comme résultat?
Il doit manquer quelque chose quelque part!
A te lire,
Cordialement
Amadéus vous informe que, pour cause de saturation, il ne peut plus répondre aux messages privés non sollicités.
j
jeanninetarten
Nouveau venu
Nouveau venu
Messages : 4
Inscrit le : 7 décembre 2014
Version d'Excel : FR2007

Message par jeanninetarten » 7 décembre 2014, 14:57

Oui, excusez moi, c'est bien 12 heures pour lundi et 8 heures pour mardi ! Je ne sais plus compter ! :o
Mais seulement j'avais déjà essayer avec une mise en forme conditionnelle, et cela ne marche pas avec les cellules fusionnées.
Et de plus j'ai besoin de mettre du texte dans mes cases de couleur, donc différent de "V","J" ou "R" ;)
Modifié en dernier par jeanninetarten le 7 décembre 2014, 15:06, modifié 3 fois.
Avatar du membre
LouReeD
Contributeur
Contributeur
Messages : 7'086
Appréciations reçues : 370
Inscrit le : 14 octobre 2014
Version d'Excel : 2013 FR, 2016 FR
Contact :
Téléchargements : Mes applications

Message par LouReeD » 7 décembre 2014, 14:59

Bonjour,

J'allais faire la même remarque, décidemment je lis trop vite !!!! ;-)

Avec mon système, un simple NBVAL(b3:F14)*2 suffit :D

@ bientôt

LouReeD
Quelques règles à lire ICI ;;)
______________________________________________________Vous pouvez allez faire un tour sur : Index de "Mes applications" ;;)
j
jeanninetarten
Nouveau venu
Nouveau venu
Messages : 4
Inscrit le : 7 décembre 2014
Version d'Excel : FR2007

Message par jeanninetarten » 7 décembre 2014, 15:06

Pareil pour nbval, ça ne marche pas avec les cellules fusionnées !
Merci de votre aide
A
Amadéus
Fanatique d'Excel
Fanatique d'Excel
Messages : 17'620
Appréciations reçues : 79
Inscrit le : 7 mai 2006
Version d'Excel : Office Excel 2003 FR et 2013FR

Message par Amadéus » 7 décembre 2014, 15:08

Bonjour
avec une fonction personnalisée (dans Module)
Cordialement
Planing.xls
(60 Kio) Téléchargé 46 fois
Amadéus vous informe que, pour cause de saturation, il ne peut plus répondre aux messages privés non sollicités.
j
jeanninetarten
Nouveau venu
Nouveau venu
Messages : 4
Inscrit le : 7 décembre 2014
Version d'Excel : FR2007

Message par jeanninetarten » 7 décembre 2014, 15:25

MERCI BEAUCOUP ! :D
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message
  • Création planning
    par chocochery » 13 octobre 2016, 09:47 » dans Excel - VBA
    5 Réponses
    293 Vues
    Dernier message par LouReeD
    18 octobre 2016, 21:29
  • Création de planning
    par erwan N » 23 avril 2020, 16:19 » dans Excel - VBA
    1 Réponses
    54 Vues
    Dernier message par erwan N
    24 avril 2020, 14:46
  • Création planning
    par fredolilo » 23 avril 2020, 12:24 » dans Excel - VBA
    5 Réponses
    75 Vues
    Dernier message par JoyeuxNoel
    24 avril 2020, 19:43
  • création planning
    par Arno51 » 20 septembre 2018, 12:53 » dans Excel - VBA
    5 Réponses
    221 Vues
    Dernier message par Arno51
    24 septembre 2018, 14:14
  • Création planning
    par ben2510 » 14 novembre 2017, 12:23 » dans Excel - VBA
    3 Réponses
    312 Vues
    Dernier message par h2so4
    15 novembre 2017, 13:07
  • Création d'un planning
    par madvx » 30 juin 2017, 18:43 » dans Excel - VBA
    20 Réponses
    436 Vues
    Dernier message par madvx
    2 juillet 2017, 16:17