Compter un nombre de variables différentes selon un critère

Y compris Power BI, Power Query et toute autre question en lien avec Excel
h
harry
Jeune membre
Jeune membre
Messages : 23
Inscrit le : 30 mars 2013
Version d'Excel : 2007FR

Message par harry » 30 novembre 2014, 20:36

Bonjour,

Le fichier ci-joint vous exposera mieux mon problème. Il s'agit de compter le nombre de variables différentes selon un critère, dans une colonne qui peut comporter des cellules vides. Si possible sans macros. Merci à celle ou celui qui voudra bien me répondre. Harry
NBRE VARIABLE DIFF. CRITERES.xlsx
(10.14 Kio) Téléchargé 22 fois
M
Max6546
Membre fidèle
Membre fidèle
Messages : 255
Inscrit le : 19 avril 2013
Version d'Excel : 2010

Message par Max6546 » 30 novembre 2014, 21:02

BOnjour,

En E2:
=SIERREUR(INDEX(C2:C5;EQUIV(VRAI;ESTNUM(CHERCHE(A2:A17;A2));0));"")
a valider avec Ctrl Shif Entrée (fonction matricielle)

Max
Avatar du membre
Jean-Eric
Fanatique d'Excel
Fanatique d'Excel
Messages : 14'271
Appréciations reçues : 399
Inscrit le : 27 août 2012
Version d'Excel : O365 32 bits

Message par Jean-Eric » 30 novembre 2014, 21:12

Bonjour,
Une proposition avec tableau (dynamique) et TCDs (tableaux croisés dynamiques)
Cdlt.
NBRE VARIABLE DIFF. CRITERES.xlsx
(16.57 Kio) Téléchargé 22 fois
Jean-Eric

Je ne réponds pas aux M.P. non sollicités.
h
harry
Jeune membre
Jeune membre
Messages : 23
Inscrit le : 30 mars 2013
Version d'Excel : 2007FR

Message par harry » 30 novembre 2014, 22:27

bonjour et merci pour vos réponses,

Je suis désolé mais la première solution ne fonctionne pas. Pour la seconde je ne maîtrise pas les TCD. Je pense vraiment qu'il est possible d'effectuer ces calculs, probablement avec une fonction matricielle.
Je chercherai encore, et merci de votre aide.

Harry
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message