Formules automatiques pour calcul de commissions Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
z
zoelea
Jeune membre
Jeune membre
Messages : 12
Inscrit le : 24 novembre 2014
Version d'Excel : 2010

Message par zoelea » 24 novembre 2014, 16:50

Bonjour à tous,

J'aurais aimé de l'aide pour réaliser un tableau où je peux calculer les commissions de mes commerciaux.

Je m'explique, ils ont des tranches par ex entre 6000 et 15000 on a des commissions de 10%, ensuite entre 15001 et 25000 par exemple ils ont 15% et ainsi de suite !!

J'aurais voulu pouvoir indiquer dans une case d'excel le montant total de leur commissions et ensuite tous les résultats seraient calculés en automatiques.

J'ai joint un tableau pour que vous compreniez un peu mieux, c'est pas évident à expliquer !!

Merci d'avance pour votre aide !!
Exemple.xls
(38.5 Kio) Téléchargé 374 fois
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'300
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 24 novembre 2014, 17:31

Bonjour le forum,
=SI(C6>24000;2000+(C6-24000)*0,2;SI(C6>20000;1400+(C6-20000)*0,15;SI(C6>6000;(C6-6000)*0,1;0)))
mbbp
z
zoelea
Jeune membre
Jeune membre
Messages : 12
Inscrit le : 24 novembre 2014
Version d'Excel : 2010

Message par zoelea » 24 novembre 2014, 17:39

Bonjour,

Merci pour la formule mais à priori ça ne fonctionne pas sauf si je ne sais pas m'en servir je dois l'a mettre où cette formule dans mon tableau ??

J'ai un message d'incohérence !!

Merci
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'300
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 24 novembre 2014, 17:49

Re,

En D6 par exemple et tu fais varier le montant des encaissements en C6.

Autre formule :
=SOMME(($C$6:$C$10-$C$5:$C$9)*(CA-$B$5:$B$9+ABS(CA-$B$5:$B$9)))/2
Formule matricielle à valider avec CTRL MAJ ENTREE

mbbp
z
zoelea
Jeune membre
Jeune membre
Messages : 12
Inscrit le : 24 novembre 2014
Version d'Excel : 2010

Message par zoelea » 24 novembre 2014, 18:21

Excellent !!

La première solution fonctionne bien mais le seul soucis c'est que j'ai une dizaine d'autres cas différents et il faudrait que je fasse des créations mais je n'arrive pas à comprendre la formule !!

Du coup j'ai voulu essayer votre deuxième solution qui me parait être plus simple pour mes autres créations mais je dois mal faire les choses ça ne fonctionne pas j'ai entré la formule dans la case F3 mais ça ne donne rien comment je dois faire j'ai du mal placer cette formule mais quand je double clique sur la formule je vois bien que mes 30000 ne sont pas intégrés comment je peux faire ??

Désolé je ne suis pas super à l'aise dans les formules !!

Merci d'avance
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'300
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 24 novembre 2014, 18:25

Re,

La formule est matricielle : elle est à valider avec les touches CTRL MAJ ENTREE

mbbp
Barème par tranches.xlsx
(10.7 Kio) Téléchargé 270 fois
z
zoelea
Jeune membre
Jeune membre
Messages : 12
Inscrit le : 24 novembre 2014
Version d'Excel : 2010

Message par zoelea » 24 novembre 2014, 18:39

Excellent voilà ce qu'il me faut !!!

Une dernière chose !! si je veux copier tout ça dans un autres onglet pour créer un autre commercial comment je peux faire le copier coller normal ne reprend pas les calculs !!

Et ensuite tout devrait être parfait !!

Merci
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'300
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 24 novembre 2014, 18:45

Re,

Si tu copies l'onglet : clic droit sur l'onglet : "Déplacer ou copier" : cocher : "Créer une copie"

la formule se retrouve dans la nouvelle feuille.

mbbp
z
zoelea
Jeune membre
Jeune membre
Messages : 12
Inscrit le : 24 novembre 2014
Version d'Excel : 2010

Message par zoelea » 24 novembre 2014, 18:48

Et voilà c'est excellent me voilà prêt pour mes autres commerciaux !!

En tout cas merci beaucoup !!!!!

Il ne me reste plus qu'à valider tout ça.

Merci et à bientôt
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message