Arrondir à chaque 50

Y compris Power BI, Power Query et toute autre question en lien avec Excel
S
ShadowBob
Nouveau venu
Nouveau venu
Messages : 4
Inscrit le : 10 novembre 2014
Version d'Excel : 2010

Message par ShadowBob » 10 novembre 2014, 17:36

Bonjour, je cherche à mettre en place une formule me permettant d'arrondir un chiffre à la cinquantaine supérieur mais + 50 si on tombe sur une centaine.
Je m'explique, si on entre 602, on trouve 650 grâce à =PLAFOND(B2;50), ça c'est ok.
Or quand on entre 652, on trouve 700, et j'aimerais que l'on obtienne 750.
En gros, on doit obtenir uniquement des chiffres terminant par 50 (450, 550, 650, 750, ...)
J'espère avoir était clair et obtenir de l'aide :D
f
frangy
Passionné d'Excel
Passionné d'Excel
Messages : 4'337
Appréciation reçue : 1
Inscrit le : 19 novembre 2012
Version d'Excel : 2007 FR

Message par frangy » 10 novembre 2014, 18:01

Bonjour,

Il y a sûrement plus simple :D
=ARRONDI.AU.MULTIPLE(B2/10;10)*10+50

A+
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'300
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 10 novembre 2014, 18:11

Bonsoir le forum,

=SI(DROITE(PLAFOND(B2;50);2)="50";(PLAFOND(B2;50));(PLAFOND(B2;50)+50))

mbbp
Avatar du membre
OOoiste
Membre impliqué
Membre impliqué
Messages : 1'606
Appréciations reçues : 22
Inscrit le : 1 octobre 2009
Version d'Excel : office 365

Message par OOoiste » 10 novembre 2014, 18:13

Bonsoir,
=ARRONDI.AU.MULTIPLE(B2-50;100)+50
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'300
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 10 novembre 2014, 18:18

Re,
=SI(DROITE(PLAFOND(B2;50);2)="00";(PLAFOND(B2;50)+50);SI(DROITE(PLAFOND(B2;50);2)="50";(PLAFOND(B2;50));(ENT((B2)/50)*50)+100))
mbbp
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'300
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 11 novembre 2014, 11:17

Re,

Une dernière pour la route.
=SI(B2<50;50;PLAFOND(B2-50;100)+50)
mbbp
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message
  • Arrondir
    par mrtgrdn » 20 juin 2016, 13:55 » dans Excel - VBA
    6 Réponses
    189 Vues
    Dernier message par Jean-Eric
    21 juin 2016, 11:17
  • arrondir
    par JST01 » 14 mai 2016, 18:13 » dans Excel - VBA
    4 Réponses
    224 Vues
    Dernier message par JST01
    24 novembre 2016, 14:14
  • arrondir
    par ilien » 6 avril 2018, 13:16 » dans Excel - VBA
    2 Réponses
    126 Vues
    Dernier message par ilien
    6 avril 2018, 13:43
  • Arrondir au dixième
    par Stevenn » 1 juin 2016, 17:45 » dans Excel - VBA
    4 Réponses
    479 Vues
    Dernier message par Stevenn
    1 juin 2016, 18:06
  • Arrondir nombre
    par Opak » 10 mars 2020, 10:44 » dans Excel - VBA
    2 Réponses
    30 Vues
    Dernier message par Pedro22
    10 mars 2020, 10:59
  • Arrondir vba
    par abdernino » 26 novembre 2019, 21:47 » dans Excel - VBA
    2 Réponses
    48 Vues
    Dernier message par abdernino
    26 novembre 2019, 22:09