SI et DATE

Y compris Power BI, Power Query et toute autre question en lien avec Excel
c
chtiguitare
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 20 août 2014
Version d'Excel : Calc3.6

Message par chtiguitare » 20 août 2014, 15:00

Bonjour à tous,

J'ai un soucis avec une formule: je dois ajouter à une date de départ 8 mois ou 10 mois en fonction d'une ville.

Colonne 1 Colonne 2 Colonne 3
20/08/2014 PARIS Date??
18/08/2014 Lyon ?
19/08/2014 PARIS ???
17/08/2014 Paris ?




J'ai essayé cela comme formule mais ça ne marche pas =SI(B9="Paris";F9=DATE(ANNEE(F9);MOIS(F9)+8;JOUR(F9));");MOIS(F9)+10")

D'avance merci pour vos réponses :P

NB désolé pour la mise en forme
A
Amadéus
Modérateur
Modérateur
Messages : 17'744
Appréciations reçues : 76
Inscrit le : 7 mai 2006
Version d'Excel : Office Excel 2003 FR et 2013FR

Message par Amadéus » 20 août 2014, 15:07

Bonjour. bienvenue sur le Forum
Avec MOIS.DECALER
Cordialement
Dates.xls
(14 Kio) Téléchargé 3 fois
Amadéus vous informe que, pour cause de saturation, il ne peut plus répondre aux messages privés non sollicités.
c
chtiguitare
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 20 août 2014
Version d'Excel : Calc3.6

Message par chtiguitare » 20 août 2014, 15:29

Bonjour Amadéus,

J'avais essayé avec cela: =SI(K4="Paris";F4=MOIS.DECALER(F4;8);"")

Mais il met une date au 31/12/1899 :( ???? une idée? D'avance merci
A
Amadéus
Modérateur
Modérateur
Messages : 17'744
Appréciations reçues : 76
Inscrit le : 7 mai 2006
Version d'Excel : Office Excel 2003 FR et 2013FR

Message par Amadéus » 20 août 2014, 15:49

Bonjour
J'avais essayé avec cela: =SI(K4="Paris";F4=MOIS.DECALER(F4;8);"")
ta formule n'est pas applicable en F4
elle le serait en G4 avec
=SI(K4="Paris";G4=MOIS.DECALER(F4;8);"")
sinon, pour modifier la date en F4, tu dois passer non par une formule, mais par un code VBA
Cordialement
Amadéus vous informe que, pour cause de saturation, il ne peut plus répondre aux messages privés non sollicités.
c
chtiguitare
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 20 août 2014
Version d'Excel : Calc3.6

Message par chtiguitare » 20 août 2014, 16:22

Ok merci, j 'ai essayé mais même en G4, la date et au 31/12/1899.

Y 'a rien faire :roll: ?
A
Amadéus
Modérateur
Modérateur
Messages : 17'744
Appréciations reçues : 76
Inscrit le : 7 mai 2006
Version d'Excel : Office Excel 2003 FR et 2013FR

Message par Amadéus » 20 août 2014, 17:06

Bonjour
Y 'a rien faire ?
Si!
Envoyer ton fichier que nous puissions voir ton erreur.
cordialement
Amadéus vous informe que, pour cause de saturation, il ne peut plus répondre aux messages privés non sollicités.
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'389
Appréciations reçues : 244
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 20 août 2014, 17:17

Bonjour le forum,
chtiguitare a écrit : je dois ajouter à une date de départ 8 mois ou 10 mois en fonction d'une ville.
F9 : =SI(B1="PARIS";DATE(ANNEE(A1);MOIS(A1)+8;JOUR(A1));DATE(ANNEE(A1);MOIS(A1)+10;JOUR(A1)))

mbbp
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message