Optimiser formule

Y compris Power BI, Power Query et toute autre question en lien avec Excel
T
Tonio620
Jeune membre
Jeune membre
Messages : 31
Inscrit le : 5 mai 2014
Version d'Excel : 2010

Message par Tonio620 » 5 août 2014, 09:00

Bonjour tout le monde,

J'ai un fichier qui ram à cause de cette formule : =SI(D3&E3="";"";(SI($D3="";RECHERCHEV($E3;'Base de données'!$B:$FU;8;FAUX);RECHERCHEV($D3;'Base de données'!$1:$1048576;9;FAUX))))

Le fichier en question est un planning qui maximum contient 52 feuilles (une feuille par semaine) et je ne peux pas le fractionner.
Mon fichier ram déjà sachant qu'il n'y a que 4 feuilles. Comment puis je faire pour l'optimiser ?

Merci :D
Avatar du membre
Patrice33740
Membre dévoué
Membre dévoué
Messages : 563
Appréciations reçues : 48
Inscrit le : 27 juillet 2014
Version d'Excel : FR, 2007, 2003, 2013, 2016

Message par Patrice33740 » 5 août 2014, 09:13

Bonjour,

Je suppose que tu n'utilises pas la totalité de la feuille "base de données", au lieu de faire la rechercheV sur la totalité des lignes ou la totalité des colonnes, désignes uniquement la plage de données utilisée
Cordialement
Patrice

Personne ne peut détenir le savoir, c'est pour ça qu'on le partage.
T
Tonio620
Jeune membre
Jeune membre
Messages : 31
Inscrit le : 5 mai 2014
Version d'Excel : 2010

Message par Tonio620 » 5 août 2014, 10:37

Bonjour Patrice33740,
Merci pour ta réponse mais je viens d'essayer et cela ne change rien :(
Avatar du membre
Patrice33740
Membre dévoué
Membre dévoué
Messages : 563
Appréciations reçues : 48
Inscrit le : 27 juillet 2014
Version d'Excel : FR, 2007, 2003, 2013, 2016

Message par Patrice33740 » 5 août 2014, 13:45

Re,
Ça change forcement quelque chose mais ce n'est peut-être pas suffisant, quelle formule as-tu employé ?
Le problème n'est peut-être pas cette formule !!
Sans le fichier, c'est impossible d'analyser le problème.r
Cordialement
Patrice

Personne ne peut détenir le savoir, c'est pour ça qu'on le partage.
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message