Calculs intervalles de temps

Bonjour à tous !

J'essaie de réaliser un petit calcul sous Excel mais j'ai un léger problème lorsqu'il agit de prendre en considération le calcul précédent.

Je dois en fait calculer des intervalles de temps de prélèvement (prélèvements répétés) par patient en heures.

Mon erreur de calcul se situe à partir du deuxième prélèvement pour un même patient.

Je vous mets en pièces jointes le fichier afin que vous compreniez mon problème.

19calculs.xlsx (10.84 Ko)

Merci d'avance pour votre aide !

Bonjour,

tu ne veux pas expliquer en clair ce que tu veux ?

Si on n'a qu'une formule que tu dis erronée pour deviner ce n'est pas simple...

eric

Pour chaque patient nous avons 3 paramètres sur lesquels seront déterminés les intervalles de temps :

un identifiant patient (col A), un code (col B) et une date de prélèvement (col C).

J'entre la formule suivante dans ma colonne de calculs des intervalles de temps :

=SI(A1<>A2;0;SI(ET(A1=A2;B1=B2);ENT((C2-C1)*24);SI(ET(A2=A1;B2<>B1);ENT((C2-C1)*24);"")))

Problème : celle ci ne prends pas en considération l’intervalle de temps d'un premier prélèvement calculé pour un même patient. L'erreur se situe à la deuxième condition puisque j'obtiens les résultats suivants :

Id_P Code Date_prelevement Intervalle

1903 1599 04/02/2014 17:50 0

1903 1599 04/02/2014 17:50 0

1903 1599 04/02/2014 17:50 0

2634 1395 17/09/2013 20:00 0

2634 1395 17/09/2013 20:00 0

2634 1395 17/09/2013 20:00 0

2634 1400 18/09/2013 00:01 4

2634 1400 18/09/2013 00:01 0

2634 1400 18/09/2013 00:01 0

L'intervalle en D8 doit être égal à D7 car même identifiant patient,même code prélèvement et même date.

à tester :

=SI(A2<>A1;0;SI(B2=B1;D1;ENT((C2-C1)*24)))

eric

Bonjour,

Avec une procédure, à adapter et à tester pour voir si tous les cas sont rencontrés.

18calculs.xlsm (24.36 Ko)
Rechercher des sujets similaires à "calculs intervalles temps"