Formule à plusieurs "SI" Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
I
IrishLily
Jeune membre
Jeune membre
Messages : 18
Inscrit le : 6 juin 2014
Version d'Excel : 2010

Message par IrishLily » 2 juillet 2014, 10:06

Bonjour,

J'ai une base de donnée avec une colonne Energie, où j'ai soit des cellules du type W/5 par exemple, soit des cellules avec des nombres en km/h. J'ai besoin de créer un graphique croisé dynamique, c'est pourquoi j'ai rajouté à côté de cette colonne Energie une colonne EnergieNum.

J'ai traité le cas où j'ai des cellules en W, et j'ai la formule SI(O3="W";0;-CNUM(SUBSTITUE(O3;"W/";""))) qui me permet ensuite de tracer une ordonnée en W/... .


Je voudrais écrire une formule qui permette de dire :

Si la cellule contient le texte "W", alors écrire SI(O3="W";0;-CNUM(SUBSTITUE(O3;"W/";"")))

Sinon, Si elle contient le texte "km/h", alors écrire SI(O3="10 km/h";0;-CNUM(SUBSTITUE(O3;"km/h";"")))

Sinon, ne rien écrire dans la cellule.

J'ai écrit la formule suivante pour la cellule O3 (la première de la colonne EnergieNum):

=SI(NB.SI(O3;"*W*");SI(O3="W";0;-CNUM(SUBSTITUE(O3;"W/";"")));(SI(NB.SI(O3;"*km/h*");SI(O3="10 km/h";0;-CNUM(SUBSTITUE(O3;"km/h";"")));O3="")))

Cela marche pour W et W/..., et ... km/h, Excel me renvoie ce que je veux.
Par contre pour une cellule qui contient autre chose, il me renvoie FALSE, et si la cellule est vide il me renvoie TRUE, alors que je lui ai demandé de me renvoyer "" . Je ne comprend pas où est mon erreur, quelqu'un pourrait-il m'aider ?

Je vous remercie ! :)
h
h2so4
Passionné d'Excel
Passionné d'Excel
Messages : 8'978
Appréciations reçues : 359
Inscrit le : 16 juin 2013
Version d'Excel : 365 UK Windows 10

Message par h2so4 » 2 juillet 2014, 10:56

Bonjour,

essaie ceci
=SI(NB.SI(O3;"*W*");SI(O3="W";0;-CNUM(SUBSTITUE(O3;"W/";"")));(SI(NB.SI(O3;"*km/h*");SI(O3="10 km/h";0;-CNUM(SUBSTITUE(O3;"km/h";"")));"")))
peux-tu expliquer le résultat que tu voulais obtenir en écrivant ceci O3="" quand toutes les conditions sont fausses ?

Comme tu l'as écrit cela te donne le résultat de la comparaison entre O3 et "" soit VRAI ou FAUX, le résultat que tu ne comprenais pas.

Si tu veux effacer le contenu de O3, ce ne sera pas possible avec une formule qui ne se trouve pas dans O3. Si tu ne peux pas mettre de formule dans O3, il faudra passer par du VBA.
Modifié en dernier par h2so4 le 2 juillet 2014, 11:26, modifié 1 fois.
I
IrishLily
Jeune membre
Jeune membre
Messages : 18
Inscrit le : 6 juin 2014
Version d'Excel : 2010

Message par IrishLily » 2 juillet 2014, 11:13

Super, c'est parfait !
Je vois, j'ai compris mon erreur.
En écrivant O3="", je voulais que la cellule soit vide si il n'y avait ni W, ni km/h mais par exemple "/" ou une cellule vide.

Un grand merci à vous pour avoir pris le temps de m'aider ! :)
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message