Index Equivalent Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
M
Max6546
Membre fidèle
Membre fidèle
Messages : 255
Inscrit le : 19 avril 2013
Version d'Excel : 2010

Message par Max6546 » 28 juin 2014, 12:50

Bonjour,

Actuellement j'utilise la formule suivante:
=SIERREUR(SI(RECHERCHEV(G2;Conversion!D:E;2;0)=AUJOURDHUI();"On time";SI(RECHERCHEV(G2;Conversion!D:E;2;0)>AUJOURDHUI();"Advance";"Late"));"")

J'ai recemment découvert les formules magiques étant Index Equvalent, afin de ne pas avoir à décaler les colonnes avec les rehcercheV, je cherche à appliquer la même formule avec index equivalent.

Malheureusment, je bute:
=SIERREUR(SI(INDEX(Feuil1!$E$2:$E$741;EQUIV(Séquence!A2;Feuil1!$D$2:$D$741;0)=AUJOURDHUI();"On time";SI(INDEX(Feuil1!$E$2:$E$741;EQUIV(Séquence!B2;Feuil1!$D$2:$D$741;0)>AUJOURDHUI();"Advance";"Late")));"")
Quelqu'un aurait-il une idée?

En vous remerciant

Max
Avatar du membre
Nad
Passionné d'Excel
Passionné d'Excel
Messages : 4'861
Appréciation reçue : 1
Inscrit le : 16 mars 2008
Version d'Excel : 2003 FR - 2007 FR

Message par Nad » 28 juin 2014, 12:54

Bonjour

Merci de joindre ton fichier

Amicalement
Nad
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'398
Appréciations reçues : 208
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 28 juin 2014, 13:50

bonjour ;bonjour Nad
INDEX fonctionne de la façon suivante
- 1) tu renseignes le n° de ligne avec Equiv : c'est bien; mais ::B- il te manque un detail ;c'est le n° de colonne ,donc
-2) au lieu de chercher dans une seule colonne (E:E) tu peux comme avec recherchev, indiquer la colonne ; c'est le 2eme argument de Index ; ce 2eme argument peux tres bien etre obtenu avec Equiv ou encore une valeur qui par exemple peux se trouver dans une cel contenant une liste de validation (1,2,3,4,5,6.....) ainsi il est possible d'aller fouiller dans des colonnes multiples en fonction du choix dans cette fameuse cell
si ton probleme n'est pas là ;le post de Nad est de rigueur
cordialement
c'est en cherchant qu'on trouve
M
Max6546
Membre fidèle
Membre fidèle
Messages : 255
Inscrit le : 19 avril 2013
Version d'Excel : 2010

Message par Max6546 » 28 juin 2014, 14:06

Bonjour,

Je vous joins le fichier.

C'est en colonne B que je cherche à mettre en place la formule:

Si colonne A (date au format ERP yyyywwdd) est inférieur à aujourd'hui alors late, égale à aujourd'hui alors On time, sinon advance.

Merci, je vais essayer de mon côté.

BR

max

essais index.xlsx
(31.52 Kio) Téléchargé 5 fois
Avatar du membre
Nad
Passionné d'Excel
Passionné d'Excel
Messages : 4'861
Appréciation reçue : 1
Inscrit le : 16 mars 2008
Version d'Excel : 2003 FR - 2007 FR

Message par Nad » 28 juin 2014, 15:20

Re

Attention d'adapter ton fichier à ta demande
J'ai repris le nom de l'onglet de la formule RECHERCHEV et G2 est devenu A1
=SIERREUR(SI(INDEX(CONVERSION!E:E;EQUIV(A1;CONVERSION!D:D;0))=AUJOURDHUI();"On Time";SI(INDEX(CONVERSION!E:E;EQUIV(A1;CONVERSION!D:D;0))>AUJOURDHUI();"Advance";"Late"));"")
Nad
M
Max6546
Membre fidèle
Membre fidèle
Messages : 255
Inscrit le : 19 avril 2013
Version d'Excel : 2010

Message par Max6546 » 28 juin 2014, 16:43

Nad a écrit :Re

Attention d'adapter ton fichier à ta demande
J'ai repris le nom de l'onglet de la formule RECHERCHEV et G2 est devenu A1
=SIERREUR(SI(INDEX(CONVERSION!E:E;EQUIV(A1;CONVERSION!D:D;0))=AUJOURDHUI();"On Time";SI(INDEX(CONVERSION!E:E;EQUIV(A1;CONVERSION!D:D;0))>AUJOURDHUI();"Advance";"Late"));"")
Nad
Je te remercie grandement.

Amicalement

Max
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message