équivalent de somme de SI

Y compris Power BI, Power Query et toute autre question en lien avec Excel
g
guimo89
Jeune membre
Jeune membre
Messages : 17
Inscrit le : 25 avril 2014
Version d'Excel : 2010

Message par guimo89 » 30 avril 2014, 21:36

Bonjour,

J'aimerais savoir quel serait l'équivalent de la formule suivante beaucoup trop lourde:
=SI(A1=B1;C1;0)+SI(A2=B2;C2;0)+...SI(A12=B12;C12;0)

merci!
Avatar du membre
OOoiste
Membre impliqué
Membre impliqué
Messages : 1'600
Appréciations reçues : 19
Inscrit le : 1 octobre 2009
Version d'Excel : office 365

Message par OOoiste » 30 avril 2014, 21:42

Bonsoir,
=SOMMEPROD((A1:A12=B1:B12)*C1:C12)
A+
g
guimo89
Jeune membre
Jeune membre
Messages : 17
Inscrit le : 25 avril 2014
Version d'Excel : 2010

Message par guimo89 » 30 avril 2014, 21:54

Bonsoir,

Malheureusement j'avais essayé cette formule mais cela ne fonctionne pas, voir ma case gain:
ici mon fichier: http://we.tl/Mr8x275nbC

merci de votre aide
Avatar du membre
R@chid
Membre impliqué
Membre impliqué
Messages : 2'754
Appréciations reçues : 35
Inscrit le : 14 novembre 2012
Version d'Excel : 2019 FR

Message par R@chid » 1 mai 2014, 04:16

Bonjour @ tous,
L'ami OOoiste t'a donné la bonne formule, mais tu n'as pas fait comme il a fait lui,

Ta formule sur le fichier :
=SOMMEPROD((N11:N14=E11:E14);L11:L14)
Correction :
=SOMMEPROD((N11:N14=E11:E14)*L11:L14)
Ou,
=SOMMEPROD(N(N11:N14=E11:E14);L11:L14)
@ + +
"Donnez moi un point d'appui et je soulèverai le monde"
g
guimo89
Jeune membre
Jeune membre
Messages : 17
Inscrit le : 25 avril 2014
Version d'Excel : 2010

Message par guimo89 » 1 mai 2014, 13:03

ah oui effectivement seul ce code marche par contre,
=SOMMEPROD(N(N11:N14=E11:E14);L11:L14)
L'autre code
=SOMMEPROD((N11:N14=E11:E14)*L11:L14)
m'affiche #valeur probablement parce que certaines cases de la colonne sont vides.

Pouvez-vous m'expliquer à quoi sert le N avant
(N11:N14=E11:E14);L11:L14)
?

Un grand merci à vous, je connaissais simplement le sommeprod classique entre matrices, mais en fait cette fonction est surpuissante pour les conditions!!(que je ne gère pas bien avec cette formule...)
Avatar du membre
R@chid
Membre impliqué
Membre impliqué
Messages : 2'754
Appréciations reçues : 35
Inscrit le : 14 novembre 2012
Version d'Excel : 2019 FR

Message par R@chid » 1 mai 2014, 13:40

Bonjour,
Le N() est là pour convertir les VRAI et FAUX renvoyer par N11:N14=E11:E14 en valeurs numériques VRAI=1 et FAUX=0.

SI cette formule =SOMMEPROD((N11:N14=E11:E14)*L11:L14) te renvoie des valeurs d'erreurs #VALEUR! cela veut dire que la plage L11:L14 contient des valeurs textes.


@ + +
"Donnez moi un point d'appui et je soulèverai le monde"
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message