Délai et jours ouvrés

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Q
QUIRIN
Nouveau venu
Nouveau venu
Messages : 5
Inscrit le : 23 janvier 2008

Message par QUIRIN » 2 avril 2008, 09:54

Bonjour!

J'ai une application à mettre à jour pour mon boulot et ça fait deux jours que je me prend la tête dessus, j'espère que quelqu'un pourra m'aider.

Le but de l'application est de comparer le délai mis par notre service par rapport à un cahier des charges.

délai à respecter en jours ouvrés (colonne D):
5 jours pour le cas 1 (X) (test de comparaison avec la cellule $C$463 pour détecter ce cas)
21 jours pour le cas 2 (Z) (test de comparaison avec la cellule $C$464 pour détecter ce cas)

En entrée on a une date de demande officiel (colonne E), une date de demande fournisseur (colonne M) et une date de réalisation (colonne H).


condition 1 : si la demande du fournisseur (M) est inférieur à " la date officiel + le délai " on se base sur " la date officiel + le délai ", donc si la date de réalisation est inférieur à " la date officiel + le délai " c'est OK sinon ce n'est pas bon

condition 2 : si la demande du fournisseur (M) est supérieur à " la date officiel + le délai " on se base sur la demande du fournisseur, donc si la date de réalisation est inférieur à la date du fournisseur c'est OK sinon ce n'est pas bon


Dans la (colonne K) je calcul le délai en jours ouvrés :
=SI(C4=$C$472;SI(ET(H4<>"";M4<>"");SI(ESTNUM(M4);ABS(NB.JOURS.OUVRES(H4;M4;'Jours Férié'!$A$2:$A$22))-1;"");"");SI(OU(C4=$C$463;C4=$C$464);SI(ET(H4<>"";E4<>"");SI(ESTNUM(M4);ABS(NB.JOURS.OUVRES(E4;H4;'Jours Férié'!$A$2:$A$22))-1;"");"");SI(ET(J4<>"";E4<>"");NB.JOURS.OUVRES(E4;J4;'Jours Férié'!$A$2:$A$14)-1;"")))

Ce calcul marche parfaitement pour la condition 1.

J'ai également la colonne L qui compare le délai de la colonne K par rapport au cahier des charges colonne D.
J'utilise donc cette colonne pour tester la condition 2 :
=SI(K4<>"";SI(OU(C4=$C$463;C4=$C$464);SI((NB.JOURS.OUVRES(M4;E4+D4;'Jours Férié'!$A$2:$A$22)-1)<0;SI(H4>M4;"N";"O");SI(K4>D4;"N";"O"));SI(ET(C4<>$C$463;C4<>$C$464;K4>D4);"N";"O"));"")

Comme vous pouvez le voir, pour mes deux conditions je fais la différence entre " la date officiel + le délai " et la date du fournisseur, si elle est inférieur à zéro cela signifie que la date du fournisseur est supérieur à la " la date officiel + le délai " (condition 2) et à ce moment si c'est vrai je compare la date de réalisation avec la demande du fournisseur.

Problème :
Dans la formule ci-dessus, lors du calcul du nombre de jours ouvrés j'ajoute le délai à respecter en jours ouvrés à la date officel (E4+D4), et de ce fait la date obtenu ne correpond pas au calendrier des jours ouvrés.
Comment résoudre ce problème sans passer par l'utilisation d'une boucle sous VBA?


Merci d'avance
Avatar du membre
Raja
Passionné d'Excel
Passionné d'Excel
Messages : 5'209
Appréciations reçues : 14
Inscrit le : 3 février 2008
Version d'Excel : 2010 à 2016 FR et 2010 EN

Message par Raja » 2 avril 2008, 10:12

Bonjour,

Si tu peux joindre un fichier et expliquer ton besoin, ça sera plus facile d'apporter une solution adaptée à ton cas. Merci de passer par ce lien suivant : Joindre un fichier

Cdlt,
Modifié en dernier par Raja le 2 avril 2008, 10:44, modifié 2 fois.
Cdlt,
Raja
d
dre
Membre impliqué
Membre impliqué
Messages : 1'995
Inscrit le : 18 mai 2007
Version d'Excel : 2003 FR

Message par dre » 2 avril 2008, 10:15

Bonjour,

Difficile de "cerner" le problème (non la question).
Ce serait plus facile avec un petit exemple en pièce jointe, reprenant uniquement les données nécessaires au fonctionnement des formules, ainsi que le résultat souhaité.
dré
Q
QUIRIN
Nouveau venu
Nouveau venu
Messages : 5
Inscrit le : 23 janvier 2008

Message par QUIRIN » 2 avril 2008, 11:31

J'ai mis un exemple du fichier sous le lien suivant.
https://www.excel-pratique.com/~files/do ... uvrA_s.xls

En fait ce que je recherche, c'est à ajouter à une date 5 ou 21 jours ouvrés, tout simplement.
Avatar du membre
Raja
Passionné d'Excel
Passionné d'Excel
Messages : 5'209
Appréciations reçues : 14
Inscrit le : 3 février 2008
Version d'Excel : 2010 à 2016 FR et 2010 EN

Message par Raja » 2 avril 2008, 12:13

Re,

Avant d'aller plus loin, dans ton exemple une partie de la formule que tu utilise dans la cellule I5 n'est pas conforme.

NB.JOURS.OUVRES(J5;C5+B5;'Jours Férié'!$A$2:$A$22) alors que J5 n'est pas une date. Ce n'est pas normal.

Cdlt,
Cdlt,
Raja
Q
QUIRIN
Nouveau venu
Nouveau venu
Messages : 5
Inscrit le : 23 janvier 2008

Message par QUIRIN » 2 avril 2008, 13:06

C'est seulement pour les changements de fournisseur et les mises en service qu'on a besoin d'une date dans la colonne J.
S'il en manque c'est que l'utilisatrice devra modifier le commentaire et mettre la date à la place.
C'est son choix de ne pas ajouter de colonne et de mélanger les dates et les commentaires. Après tout, c'est elle qui s'en servira...
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message