Problème fonction Countif Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
s
stephaneguidon
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 11 janvier 2014
Version d'Excel : 2013 FR

Message par stephaneguidon » 12 janvier 2014, 14:34

Bonjour;
j'ai un problème avec une ligne de mon code VBA.
If WorksheetFunction.CountIf(Range("A1") = "oui") Then Range("A2") = "non"
Ca me surligne .CountIfs en me mettant argument non facutatif.

Merci de votre aide, car je ne comprends pas pourquoi.
Avatar du membre
Banzai64
Fanatique d'Excel
Fanatique d'Excel
Messages : 16'726
Appréciations reçues : 3
Inscrit le : 21 novembre 2010
Version d'Excel : 2003 FR (learning 2010 - 2013)

Message par Banzai64 » 12 janvier 2014, 14:40

Bonjour

Essayes
    If WorksheetFunction.CountIf(Range("A1"), "oui") Then Range("A2") = "non"
Image
Avatar du membre
Stephane Guidon
Membre fidèle
Membre fidèle
Messages : 167
Inscrit le : 20 novembre 2013
Version d'Excel : 2013 FR

Message par Stephane Guidon » 12 janvier 2014, 14:48

Merci de ta réponse.
En effet je n'ai plus le problème mais ça ne fait rien.
Aucune action ne se produit.

Ah non c'est bon j'ai trouvé j'avais oublié de mettre
End If
.
Mais ça ne donne pas le résultat que je voulais obtenir.
Car j'ai écrit ça sur Excel:
=SI(NB.SI(A1;"*oui*");"bien";"dommage")
Que j'ai essayer de retranscrire en VBA comme ceci:
If WorksheetFunction.CountIfs(Range("A1"), "oui") Then
Range("A2") = "bien"
Else
Range("A2") = "dommage"
End If
S'il n'y a pas de solution, c'est qu'il n'y a pas de problème ! --Devises Shadok--
Avatar du membre
Banzai64
Fanatique d'Excel
Fanatique d'Excel
Messages : 16'726
Appréciations reçues : 3
Inscrit le : 21 novembre 2010
Version d'Excel : 2003 FR (learning 2010 - 2013)

Message par Banzai64 » 12 janvier 2014, 15:30

Bonjour

Écris la même chose que sur la feuille Excel
Sub test()
    If WorksheetFunction.CountIf(Range("A1"), "*oui*") Then
      Range("A2") = "bien"
    Else
      Range("A2") = "dommage"
    End If
End Sub
CountIf sans le s à la fin ( ne sert à rien dans ce cas là)
Image
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message