Formule SI à plusieurs conditions Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
a
ash_egal
Jeune membre
Jeune membre
Messages : 14
Inscrit le : 18 octobre 2012
Version d'Excel : MAC2008 FR

Message par ash_egal » 30 août 2013, 14:56

Bonjour,

Il me faudrait de l'aide sur une formule "SI" comprenant de nombreuses conditions :

Selon le fichier excel ci-joint :

Il me faut que ma Rémunération (F2) soit calculée selon mes acquis (B2 & D2) selon les objectifs fixés par palier ;

Si (B2+D2)<A6 alors F2=0
Si (B2+D2)>=A6 alors F2=(B2*C6)+(D2*C7)
Si (B2+D2)>=A8 alors F2=(B2*C8)+(D2*C9)
Si (B2+D2)>=A10 alors F2=(B2*C10)+(D2*C11)
Si (B2+D2)>=A12 alors F2=(B2*C12)+(D2*C13)
Si ((B2+D2)>=A14 alors F2=(B2+D2)*C14

Est-il possible de mettre toutes ces condition ou plus de conditions dans une seule et même formule ?

Je vous remercie d'avance de votre attention.
Forum.xlsx
(32.23 Kio) Téléchargé 24 fois
f
frangy
Passionné d'Excel
Passionné d'Excel
Messages : 4'342
Appréciation reçue : 1
Inscrit le : 19 novembre 2012
Version d'Excel : 2007 FR

Message par frangy » 30 août 2013, 15:30

Bonjour,

Dans F2, tu places la formule suivante :
=SI((B2+D2)>=A14;(B2+D2)*C14;SI((B2+D2)>=A12;(B2*C12)+(D2*C13);SI((B2+D2)>=A10;(B2*C10)+(D2*C11);SI((B2+D2)>=A8;(B2*C8)+(D2*C9);SI((B2+D2)>=A6;(B2*C6)+(D2*C7);0)))))
A+
a
ash_egal
Jeune membre
Jeune membre
Messages : 14
Inscrit le : 18 octobre 2012
Version d'Excel : MAC2008 FR

Message par ash_egal » 30 août 2013, 15:38

Merci de ton retour Frangy !

J'avais commis une erreur dans mon énoncé : la condition étant en colonne B et non en colonne A mais j'ai fait le nécessaire sur mon fichier.
J'avais tenté la même formule mais en partant des conditions croissantes et non des conditions décroissantes ; lorsque j'ai vu ta formule, mes cours de lycée se sont illuminés :)

Je te remercie de m'avoir éclaircie à ce sujet !

Parfait !
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message