Assigner deux formules dans une même case

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
Y
Yves
Nouveau venu
Nouveau venu
Messages : 1
Inscrit le : 12 décembre 2007

Message par Yves » 12 décembre 2007, 17:21

Veuillez trouver plus de précision dans le document ci-joint
https://www.excel-pratique.com/~files/do ... estion.xls
p
petidani
Membre habitué
Membre habitué
Messages : 79
Inscrit le : 6 septembre 2006

Message par petidani » 12 décembre 2007, 17:36

Bonjour,

Vous pouvez utilisez une conditions d'utilisation de cellule, cad

si j6 ="" alors formule option B sinon formule option A.

En formule excel dans J11 :

=SI(J6="";J4+J8;J4-J6)
De manière simplifier qui fera toujous apparaitre la valeur de J4 si les deux cellules sont vides.

Plus élaboré:
=SI(ET(J6="";J8="");"";SI(J6="";J4+J8;J4-J6))


Voilà

Cordialement

Petidani
d
dre
Membre impliqué
Membre impliqué
Messages : 1'962
Inscrit le : 18 mai 2007
Version d'Excel : 2003 FR

Message par dre » 12 décembre 2007, 18:15

Bonjour,

La première chose à faire est d'empêcher que les deux valeurs soient inscrites et qu'une valeur différente de 500 pour J6 et de 100 pour J8 le soit aussi.
Menu Données / Validation / Personnalisé

Ensuite en J11 : =J4-J6+J8

dré
p
petidani
Membre habitué
Membre habitué
Messages : 79
Inscrit le : 6 septembre 2006

Message par petidani » 13 décembre 2007, 07:50

Bonjour,

Je n'avais pas compris votre question voici ma réponse sur votre fichier, j'utilise le VBA pour Bloquer les valeurs et vérifier qu'une seule option est choisie

https://www.excel-pratique.com/~files/do ... estion.xls

En espérant que ça réponde à votre question

Cordialement

petidani
A
Amadéus
Fanatique d'Excel
Fanatique d'Excel
Messages : 17'626
Appréciations reçues : 79
Inscrit le : 7 mai 2006
Version d'Excel : Office Excel 2003 FR et 2013FR

Message par Amadéus » 13 décembre 2007, 10:31

Bonjour Yves, dré, salut Petidani et le Forum

Une autre version

https://www.excel-pratique.com/~files/do ... tionV3.xls

Bonne journée
Amadéus vous informe que, pour cause de saturation, il ne peut plus répondre aux messages privés non sollicités.
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message