Imbriquer "SI" et "ET" sous excel Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
U
UniWorld
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 26 avril 2012
Version d'Excel : 2007FR

Message par UniWorld » 26 avril 2012, 09:41

Bonjour,

J'aimerais imbriquer les fonctions "SI" et "ET" sous excel, comment faire? Je m'explique, j'aimerais déterminer entre quelles bornes se trouve la valeur d'une de mes cellule. Pour cela je voulais faire quelque chose comme "SI ma cellule>= première valeur ET ma cellule<deuxième valeur; 1; 0" afin que si la valeur de ma cellule est comprise entre les deux autres valeur alors 1 s'affiche et sinon 0 s'affiche.
Pour faire simple, voici ce que j'aimerais obtenir, si -0,2634 est la valeur à tester

-0,8 -0,6 -0,4 -0,2 0 0,2 0,4 0,6 0,8 1 1,2

-0,2634 0 0 1 0 0 0 0 0 0 0

J'espère avoir réussi à vous expliquer mon problème de facon assez explicite.


D'avance merci pour votre aide.
Z
Zirak
Membre impliqué
Membre impliqué
Messages : 1'198
Appréciations reçues : 2
Inscrit le : 18 mai 2011
Version d'Excel : 2010 FR

Message par Zirak » 26 avril 2012, 10:15

Bonjour,

=SI(ET(valeuràcomparer>=valeur1;valeuràcomparer<valeur2);1;0)
Tu as juste à mettre les bonnes cellules ou se trouvent tes valeurs dans la formule.


Cordialement,

Edit : à moins que toutes tes valeurs de bornes soient dans 1 seule cellule et que tu veuilles le résultat sous la forme 00100000 dans une seule cellule aussi ?

Si c'est ça, je pense qu'il va falloir passer par une macro, car par formule j'ai un peu peur que cela fasse à truc à rallonge.
A méditer:

"Au fur et à mesure que vous connaissez les problèmes des autres, vous vous rendez compte que le votre n'est pas si grave."
A
Amadéus
Modérateur
Modérateur
Messages : 17'691
Appréciations reçues : 78
Inscrit le : 7 mai 2006
Version d'Excel : Office Excel 2003 FR et 2013FR

Message par Amadéus » 26 avril 2012, 10:30

Bonjour
Non, non..Zirak, la même formule pour 10 valeurs ou 1000
Exemple: La suite de nombre en A2:A12, le nombre à tester en C2
=C2&CAR(32)&REMPLACER(REPT("0 ";NBVAL(A2:A12));EQUIV(C2;A2:A12;1);1;1)
Cordialement
Classeur10.xls
(14.5 Kio) Téléchargé 12 fois
Amadéus vous informe que, pour cause de saturation, il ne peut plus répondre aux messages privés non sollicités.
U
UniWorld
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 26 avril 2012
Version d'Excel : 2007FR

Message par UniWorld » 26 avril 2012, 10:53

Merci, la fonction : =SI(ET($F$118>=Y82;$F$118<Z82);1;0) a parfaitement fonctionné :-)
Z
Zirak
Membre impliqué
Membre impliqué
Messages : 1'198
Appréciations reçues : 2
Inscrit le : 18 mai 2011
Version d'Excel : 2010 FR

Message par Zirak » 26 avril 2012, 10:54

Bonjour Amadéus,

Je ne connaissais pas la fonction REPT(), effectivement cela permet de tout mettre dans la même cellule directement, en revanche le reste de la formule ne colle pas avec le résultat demandé.

Ta formule retourne -0,2634 0 1 0 0 0 0 0 0 0 0 0

alors qu'elle devrait retourner : -0,2634 0 0 1 0 0 0 0 0 0 0

Donc le digit 1 n'est pas au bon endroit, et tu as un 0 de trop à la fin.

Il veux une comparaison entre 2 bornes pas juste trouver la valeur la plus proche, donc pour 11 valeurs de comparaison, cela fait 10 tests + la valeur à comparer soit 11 chiffres, alors que tu en retourne 12.


Cordialement,
A méditer:

"Au fur et à mesure que vous connaissez les problèmes des autres, vous vous rendez compte que le votre n'est pas si grave."
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message
  • Imbriquer de si
    par BALSE » 14 février 2018, 12:47 » dans Excel - VBA
    5 Réponses
    109 Vues
    Dernier message par BALSE
    14 février 2018, 13:01
  • Imbriquer SI OU ET
    par Bouddha62 » 28 février 2017, 14:32 » dans Calc
    2 Réponses
    455 Vues
    Dernier message par Bouddha62
    28 février 2017, 15:25
  • imbriquer si et ou
    par anaisrp » 28 novembre 2016, 20:58 » dans Excel - VBA
    5 Réponses
    163 Vues
    Dernier message par LouReeD
    28 novembre 2016, 22:23
  • Fonction si imbriquer
    par siga » 22 janvier 2018, 09:44 » dans Excel - VBA
    4 Réponses
    163 Vues
    Dernier message par siga
    22 janvier 2018, 21:23
  • Imbriquer 2 boucles
    par tben08 » 20 janvier 2016, 10:39 » dans Excel - VBA
    12 Réponses
    393 Vues
    Dernier message par Banzai64
    21 janvier 2016, 14:08
  • Excel si et ou imbriquer
    par judoka0209 » 14 février 2020, 17:29 » dans Excel - VBA
    3 Réponses
    57 Vues
    Dernier message par DjiDji59430
    14 février 2020, 18:35