lister le nb de vlaeur différentes Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
l
loloiss
Nouveau venu
Nouveau venu
Messages : 9
Inscrit le : 18 janvier 2011
Version d'Excel : 2010 fr

Message par loloiss » 19 avril 2011, 16:39

bonjour,

je débute, soyez indulgents !

je n'arrive pas a trouver: j'ai 2 colonnes 1 avec un certains nombres de fabricants, une 2eme avec les reférences pour ces fabricants.

je voudrais faire uen feuille de calcul qui:
- liste mes différents fabricants
- et pour chacun d'eux,compte le nombre de références

- comprendre comment ça marche pour ne pas a reposter d'autres questions idiotes sur ce forum ! :D
t
tulipe_3
Membre impliqué
Membre impliqué
Messages : 1'745
Inscrit le : 18 mars 2010
Version d'Excel : 2000

Message par tulipe_3 » 19 avril 2011, 16:58

bonjoour
joint un fichier ou une maquette succinte ,mais representative
pour voir si les ref sont vraiment dans une seule cellule et, si tel est le cas par quoi elles sont separées (, ; / )

en attendant : une piste passe ton tableau par Données > convertir ;tu devrais te retrouver avec une ref par colonne ensuite il yaura moyen de compter combien a chaque ligne
cordialement
c'est en cherchant qu'on trouve
l
loloiss
Nouveau venu
Nouveau venu
Messages : 9
Inscrit le : 18 janvier 2011
Version d'Excel : 2010 fr

Message par loloiss » 19 avril 2011, 17:59

a b
fabricant1 ref1
fabricant1 ref2
fabricant1 ref3
fabricant1 ref4
fabricant1 ref5
fabricant1 ref6
fabricant2 ref7
fabricant2 ref8
fabricant2 ref9
fabricant2 ref10
fabricant2 ref11
fabricant2 ref12
fabricant2 ref13
fab3 ref14
fab3 ref15
fab4 ref16

je voudrais une formule qui me permette de lister automatiquement mes fabricants (suscpetibles d'augmenter), et le nb de ref par fabricant.
d
dubois
Passionné d'Excel
Passionné d'Excel
Messages : 9'273
Inscrit le : 8 décembre 2007
Version d'Excel : Vista Office 2007FR

Message par dubois » 19 avril 2011, 19:45

Bonsoir à tous,
Sub RefFabricant()
Dim Lg%, i%
'Macros par Claude Dubois pour "loloiss" Excel-Pratique le 19/04/11
    Application.ScreenUpdating = False
        Lg = Range("a65536").End(xlUp).Row
    With Sheets("Feuil2")
        .Range("a1") = Range("a1")
        Range("a1:b1").Copy Destination:=.Range("a1") 'en-têtes
            '--- filtre sans doublons ---
        Range("a1:a" & Lg).AdvancedFilter Action:=xlFilterCopy, CriteriaRange:= _
        Range("o1:o2"), CopyToRange:=.Range("a1"), Unique:=True
        
            '--- tri (facultatif)---
        Lg = .Range("a65536").End(xlUp).Row
        .Range("a1:a" & Lg).Sort Key1:=.Range("a1"), Order1:=xlAscending, _
        Header:=xlYes, OrderCustom:=1, MatchCase:=False
            '--- compte ---
            For i = 2 To Lg
                .Cells(i, "b") = Application.CountIf(Columns("a"), .Cells(i, "a"))
            Next i
        .Range("a:b").Columns.AutoFit
    End With
End Sub
Amicalement
Claude
loloiss_Countif.xls
(39.5 Kio) Téléchargé 6 fois
Faire simple, c'est ce qui est le plus compliqué ! et vice versa (à méditer)
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'224
Appréciations reçues : 187
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 19 avril 2011, 21:14

bonsoir
voici plusieurs solutions simples en plus de vba
llois.xls
(33.5 Kio) Téléchargé 16 fois
si ok je te donnerai des explications
cordialement
c'est en cherchant qu'on trouve
l
loloiss
Nouveau venu
Nouveau venu
Messages : 9
Inscrit le : 18 janvier 2011
Version d'Excel : 2010 fr

Message par loloiss » 20 avril 2011, 10:37

merci pour vos solutions !!

je cherche une solution avec formule de calcul uniquement, pas de VBA.

la 1ere solution donnée par tulipe_4 me conviendrait, seulement je voudrais en plus que si je rajoute un ou plusieurs fabricants, ils apparaissent automatiquement dans le bilan (pour ne pas en oublier, par ex)

encore merci beaucoup !
d
dubois
Passionné d'Excel
Passionné d'Excel
Messages : 9'273
Inscrit le : 8 décembre 2007
Version d'Excel : Vista Office 2007FR

Message par dubois » 20 avril 2011, 11:10

re,

si tu a déjà lister les fabricants sans doublons,
sur Feuil2 en B2 à tirer vers le bas
=NB.SI(Feuil1!A:A;A2)
Claude
Faire simple, c'est ce qui est le plus compliqué ! et vice versa (à méditer)
t
tulipe_3
Membre impliqué
Membre impliqué
Messages : 1'745
Inscrit le : 18 mars 2010
Version d'Excel : 2000

Message par tulipe_3 » 20 avril 2011, 11:39

bonjour
=SI(ESTERREUR(INDEX($C$3:$C$180;PETITE.VALEUR(SI(Critères=G$3;LIGNE(Critères)-2;"");LIGNE($A1))));"";INDEX($C$3:$C$180;PETITE.VALEUR(SI(Critères=G$3;LIGNE(Critères)-2;"");LIGNE($A1))))
pour ce qui est de criteres Insesion>>>nom :dans reference tu rallonges la plage
ATTENTION la formule est matricielle donc apres avoir mis le curseur a la fin il faudra valider avec ctrl,maj;entrée (les 3en meme temps ) des { } vont apparaitre a chaque extremites
ensuite ne pas oublier de tirer vers le bas (incremententation)
cordialement
c'est en cherchant qu'on trouve
l
loloiss
Nouveau venu
Nouveau venu
Messages : 9
Inscrit le : 18 janvier 2011
Version d'Excel : 2010 fr

Message par loloiss » 20 avril 2011, 11:51

si je rajoute un fabricant et ses refs, il ne se rajoute pas automatiquement dans le bilan !

edit: en fait, je voudrais faire ça: http://www.excel-downloads.com/forum/10 ... ombre.html , mais sans macro, juste avec des formules de calculs
t
tulipe_3
Membre impliqué
Membre impliqué
Messages : 1'745
Inscrit le : 18 mars 2010
Version d'Excel : 2000

Message par tulipe_3 » 20 avril 2011, 13:39

re
on va faire simple :met ton fichier ou mieux une copie avec quuelques valeurs pour pouvoir se reperer ;
tu utilises AJOUTER DES FICIHIERS sinon ça va tourner en rond et plouf
a+
c'est en cherchant qu'on trouve
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message