compteur de bonnes réponses

Y compris Power BI, Power Query et toute autre question en lien avec Excel
s
souri84
Membre impliqué
Membre impliqué
Messages : 1'042
Inscrit le : 7 mai 2007
Version d'Excel : 2003 FR / 2007 UK

Message par souri84 » 7 mai 2007, 18:31

Bonjour a tous,
je travail dans la finance et je donne également des cours et des formations dans ce domaine. J'ai créé une petite application excel pour mes élèves qui choisit aléatoirement une question dans une base de données, la personne réponds et voit si sa réponse est bonne ou mauvaise. Si la réponse est mauvaise, la personne peut (enfin pourra, je n'ai pas encore créé la macro) visualiser la réponse ainsi qu'un petit commentaire explicatif.

J'aimerai insérer dans cette application une barre graphique montrant la progression du quizz... (donc ça je pense que ça ira, il faut que je cherche un peu...)

Par contre, j'aimerai insérer un compteur de bonne réponse, mais je ne vois pas du tout comment m'y prendre...

Si quelqu'un a une réponse a m'apporter...

Merci d'avance,

Cordialement
N
Nad-Dan
Passionné d'Excel
Passionné d'Excel
Messages : 7'257
Inscrit le : 27 avril 2007
Version d'Excel : 2003 FR-2007 FR-MAC 2004 FR

Message par Nad-Dan » 8 mai 2007, 19:54

Bonsoir,

Comment qualifies-tu les bonnes réponses. Par une donnée dans une colonne ??

A te lire

Dan
s
souri84
Membre impliqué
Membre impliqué
Messages : 1'042
Inscrit le : 7 mai 2007
Version d'Excel : 2003 FR / 2007 UK

Message par souri84 » 8 mai 2007, 21:38

Ben justement, je ne sais pas trop comment faire...
V
V_Elbie
Membre impliqué
Membre impliqué
Messages : 1'509
Appréciation reçue : 1
Inscrit le : 7 avril 2007
Version d'Excel : 2003FR maison-2007FR travail

Message par V_Elbie » 8 mai 2007, 21:40

Bonsoir,

Et si tu envoyais une maquette de ce que tu veux, ça permettrait de nous éclairer...

Elbie
s
souri84
Membre impliqué
Membre impliqué
Messages : 1'042
Inscrit le : 7 mai 2007
Version d'Excel : 2003 FR / 2007 UK

Message par souri84 » 8 mai 2007, 21:42

ok, je ferais ça demain, la je m'en vais,

Merci pour vos réponses,

a demain,

Souri84
Excel 2003 / Excel 2007
s
souri84
Membre impliqué
Membre impliqué
Messages : 1'042
Inscrit le : 7 mai 2007
Version d'Excel : 2003 FR / 2007 UK

Message par souri84 » 26 mai 2007, 18:50

je fais remonter le topic, il était dans le fin fond du forum, heureusement que je l'ai retrouvé, il était ente 2 fagots, je vous raconte pas....

Bon sinon, je n'ai toujours pas réussi à faire ce maudit compteur de bonne réponse... j'avais tenté de créer une macro:
sur une autre feuille du classeur, descendre d'une ligne, marquer 1 dans la colonne A (Y); et si(cellule="BONNE REPONSE"; 1;0) dans la colonne B (X).

Ensuite sur l'interface du questionnaire, on avait "vous avez X sur Y". Cette macro fonctionne très bien si je fais macro => executer la macro. Mais quand je mets le code dans un bouton, ça me mets la boite de dialogue de débogage....

Avez vous une autre soluce?
Excel 2003 / Excel 2007
B
BEURET
Membre fidèle
Membre fidèle
Messages : 155
Inscrit le : 23 avril 2007
Version d'Excel : Excel 2003

Message par BEURET » 26 mai 2007, 19:32

Bonsoir,

un petit fichier joint nous permettrait d'avoir une idé plus claire du travail à réaliser.

Cordialement.
h
henri
Membre dévoué
Membre dévoué
Messages : 884
Inscrit le : 14 mars 2007
Version d'Excel : 2003 FR

Message par henri » 27 mai 2007, 08:54

Bonjour,
un exemple de ton fichier nous aideraient plus facilement.
As tu essayé =SOMME.SI(A1:D12;"X")
ou =NB.SI(...
A +
s
souri84
Membre impliqué
Membre impliqué
Messages : 1'042
Inscrit le : 7 mai 2007
Version d'Excel : 2003 FR / 2007 UK

Message par souri84 » 27 mai 2007, 09:45

j'ai oublié de dire: renommer l'onglet "interface du questionnaire" par "interface" sinon le bouton du sommaire ne fonctionne pas....

J'avais rajouté questionnaire pour que ce soit plus clair pour vous, mais j'ai oublié de modifier la macro... donc pour un souci de simplicité, renommer l'onglet "interface du questionnaire" par "interface"
Excel 2003 / Excel 2007
h
henri
Membre dévoué
Membre dévoué
Messages : 884
Inscrit le : 14 mars 2007
Version d'Excel : 2003 FR

Message par henri » 27 mai 2007, 17:53

Bonsoir,
le lien que tu nous met ne reprend ta demande.
A +
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message