Livraison à l'heure ? YES or NO

Bonjour,

Il y a quelques jours, vous m'avez aidé avec une formule pour savoir si mon transporteur était à l'heure. Je viens avec un "SI" supplémentaire. En effet, je voudrais ajouter un "buffer" de 15min avant et 15min après pour mes livraisons qui ne respectent pas l'horaire.

Exemple du fichier en attaché :

1ère ligne du fichier : Livraison à 11:15 de la livraison 838071744. Colonne G => NO parce que ma livraison devait se dérouler entre 08:00 et 11:00.

Maintenant, si j'ajoute 15minutes avant et 15minutes après, mon nouvel horaire serait : 07:45 à 11:15 => Yes à l'heure !

D'avance un grand merci pour votre support et meilleures salutations.

Cordialement,

Bennut

6testexcel.xlsx (12.23 Ko)

Bonjour,

Essaie avec ceci :

=SI(C2<>"";SI(E2=0;"YES";SI(OU(C2<D2;ET(C2>=D2-0,0104166666666667;C2<=E2+0,0104166666666667));"YES";"NO"));"")

Merci Noël ! ça fonctionne sur mes livraisons fausses ! A quoi correspond le 0,01041677777 ?

Merci encore et bonne après-midi.

Bennut

Un jour c'est 1

Une heure c'est donc 1/24

Une minute, 1/24/60

15 minutes, 1/24/60*15

Soit 0,0104166666667

You're welcome !

Rechercher des sujets similaires à "livraison heure yes"