Formule somme cellules nommées

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
D
Dylan
Jeune membre
Jeune membre
Messages : 23
Appréciation reçue : 1
Inscrit le : 28 décembre 2017
Version d'Excel : 2013

Message par Dylan » 7 avril 2020, 17:16

Bonjour,
Je souhaiterais gagner du temps et trouver une formule qui me calcule automatiquement (comme sur le tableau récapitulatif à droite de la feuille avril) le total de chaque produit prévu.
Je sais que je peux faire =somme(noms des cellules). ou =noms des cellules additionnées.
Mais cela est super long.
Je dois faire cela pour tous mes produits (nourritures et boissons).
Pouvez-vous m'aider ?
Merci par avance
MOIS PREVISIONNEL.xlsx
(222.3 Kio) Téléchargé 4 fois
U
U. Milité
Membre impliqué
Membre impliqué
Messages : 2'030
Appréciations reçues : 143
Inscrit le : 30 novembre 2016
Version d'Excel : Office 365

Message par U. Milité » 7 avril 2020, 17:57

Bonjour,

Tu pourrais utiliser, en S2, la fonction
=SOMME.SI($C$3:$C$171;S2;$E$3:$E$171)
... sauf que tes "burgers" (entre autres !) en colonne C sont suivis d'un nombre variable de caractères d'espacement :shock:
Ça, combiné avec des cellules fusionnées en colonnes C et E, voilà qui tourne au cauchemar !!
D
Dylan
Jeune membre
Jeune membre
Messages : 23
Appréciation reçue : 1
Inscrit le : 28 décembre 2017
Version d'Excel : 2013

Message par Dylan » 7 avril 2020, 18:10

Super ! J'ai vu que cela fonctionne déjà avec bon nombre de produits, pour le mois d'avril et de mai !!

Je vous remercie infiniment, je vais gagner un temps considérable !

En revanche, malheureusement les jours d'ouverture ne sont pas les même pour les mois qui suivent.
Qu'elle formule puis-je utiliser dans ce cas ?

Merci par avance

Dylan
U
U. Milité
Membre impliqué
Membre impliqué
Messages : 2'030
Appréciations reçues : 143
Inscrit le : 30 novembre 2016
Version d'Excel : Office 365

Message par U. Milité » 7 avril 2020, 18:56

Re-bonjour,

Avant de répondre à ta nouvelle question ...
Dylan a écrit :
7 avril 2020, 18:10
cela fonctionne déjà avec bon nombre de produits, pour le mois d'avril et de mai !!
Je vous remercie infiniment, je vais gagner un temps considérable !
Que vas-tu faire avec les autres produits ??

À certains endroits, je peux encore comprendre pourquoi tu as fusionné des cellules (même si ça reste une fort mauvaise idée !) ... mais pourquoi fusionner à hauteur des "Salade composée" ::o

Si tu veux pouvoir écrire des formules qui donnent des résultats cohérents, il faut d'abord "faire le ménage": supprimer les cellules fusionnées, recopier les "sandwichs froids" sur les trois lignes qui s'y rapportent ... et supprimer tous les espaces superflus !!!
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message