Réaliser une moyenne d'une colonne sur 2. Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
M
Mathieu3004
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 4 avril 2020
Version d'Excel : 2010 FR

Message par Mathieu3004 » 4 avril 2020, 12:39

Bonjour à tous,
Dans le cadre de mon travail j'ai récemment reçu un fichier Excel. Dans la colonne A, s'affiche la moyenne de toutes les autres colonnes impaires. Exemple en A2,j'ai la moyenne des cellules C2;E2;G2 ...
Cette moyenne a été calculée à l'aide la fonction =MOYENNE((MOD(COLONNE($B$2:$G$2);2)=1)*1;$C$2:$G$2).

Si je recalcule la moyenne avec la fonction =MOYENNE($B$2:$G$2) je ne trouve pas le même résultat. J'ai vérifié et ce résultat est le bon.
Il semble que la première fonction divise par un nombre supérieur de cellule, ce qui fausse le résultat (Dans mon exemple, la première fonction divise par 4 au lieu de 3)

Je vous met un fichier d'exemple pour comprendre le problème.
Pouvez-vous m'aider sur le fonctionnement de la fonction MOYENNE((MOD(COLONNE($B$2:$YW$2);2)=1)*1;$B$2:$YW$2) ? et m'expliquer pourquoi elle ne fonctionne pas dans mon exemple ?

Merci,
Fichier Test.xlsx
(8.57 Kio) Téléchargé 10 fois
Avatar du membre
78chris
Passionné d'Excel
Passionné d'Excel
Messages : 5'608
Appréciations reçues : 421
Inscrit le : 9 juillet 2017
Version d'Excel : 2010 à 2019 + 365

Message par 78chris » 4 avril 2020, 13:29

Bonjour

Si on on est sûr que les cellules intermédiaires ne contiennent pas de chiffre, la moyenne "standard" suffit.

Sinon en formule matricielle
=MOYENNE(SI(MOD(COLONNE($B$2:$G$2);2)=1;$B$2:$G$2;""))
Chris
Quand un homme a faim, mieux vaut lui apprendre à pêcher que de lui donner un poisson.
Confucius
Avatar du membre
M12
Passionné d'Excel
Passionné d'Excel
Messages : 3'236
Appréciations reçues : 129
Inscrit le : 3 juillet 2015
Version d'Excel : 2013

Message par M12 » 4 avril 2020, 13:31

Bonjour,

Teste cette formule à valider par CTRL + MAJ + Entrée (formule matricielle)
=MOYENNE(SI(MOD(COLONNE(B2:G2);2);B2:G2))
Merci de clôturer le fil en cliquant sur le bouton V vert du post à coté du bouton EDITER si problème résolu

Je ne répond pas au message privé
F
Fatos
Membre habitué
Membre habitué
Messages : 88
Appréciations reçues : 13
Inscrit le : 17 octobre 2010
Version d'Excel : 2010 FR

Message par Fatos » 4 avril 2020, 13:57

Bonjour,
En une phrase, cette formule est une tentative ratée (si on évite une formule matricielle). Les raisons :
  • La fonction MOYENNE() prend différentes cellules ou plages de cellules en arguments pour en calculer la moyenne.
    Or, ici, le premier des deux termes est un booléen (car c'est un test), donc le résultat VRAI/FAUX sera toujours converti en 0.
    La formule écrite réalisera ainsi la moyenne entre 0 et la plage $C$2:$G$2.
  • La fonction COLONNE() renvoie le numéro de colonne d'une référence, et cela n'a pas de sens de fournir une référence à plusieurs colonnes, car le résultat sera toujours le numéro de colonne de la première, c'est-à-dire de la colonne B : 2.
Pour faciliter le traitement, pourquoi ne pas structurer les données dans un tableau de x lignes et 2 colonnes (1 colonne pour le type d'article, 1 colonne pour le poids), avec x, le nombre de "commandes" ? :roll:
À vous lire,
M
Mathieu3004
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 4 avril 2020
Version d'Excel : 2010 FR

Message par Mathieu3004 » 8 avril 2020, 16:11

Merci pour votre aide.

Effectivement en matricielle cela fonctionne. Il s'agit d'une mauvaise formule.
Le plus simple aurait été de travaillé en ligne et non pas en colonne mais le format du fichier m'était imposé.

Merci à tous
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message