Calcul d'un taux de réussite en fonction d'une date Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
R
RonanE
Nouveau venu
Nouveau venu
Messages : 5
Inscrit le : 30 mars 2020
Version d'Excel : 2016 FR

Message par RonanE » 30 mars 2020, 15:02

Bonjour à tous,

Je me permets de vous solliciter sur le sujet suivant car après pas mal de recherche sur le net je n'ai pas trouvé la réponse à mon problème.

Pour faire simple, je cherche à définir un taux de réussite (par mois) en fonction d'une autre colonne qui contient la date d'opération. Dans le fichier que vous pouvez télécharger, sur la feuille 1 se trouve "la data" et sur la feuille 2 "le nombre d'opérations par mois ainsi que le taux de réussite" que j'aimerais calculer.

Par exemple => Quel est le taux de réussite sur le mois de Mai qui contient plusieurs opérations sur la feuille 1.

C'est sans doute tout bête mais j'ai tenté avec des SI, SI ET etc. et je n'ai pas trouvé...

Par avance, merci pour votre aide!

Bonne journée,
Ronan
Test.xlsx
(10.68 Kio) Téléchargé 1 fois
Avatar du membre
Pedro22
Passionné d'Excel
Passionné d'Excel
Messages : 3'934
Appréciations reçues : 401
Inscrit le : 26 janvier 2017
Version d'Excel : 2010 FR
Version de Sheets : FR
Téléchargements : Mes applications

Message par Pedro22 » 30 mars 2020, 15:13

Bonjour,

Vous omettez un détail crucial... Il sort d'où ce taux de réussite ? En clair : à partir de quoi et comment le calcule-t-on ?
Merci de prendre 30 sec pour lire la charte du forum.
Quelques conseils : ici
R
RonanE
Nouveau venu
Nouveau venu
Messages : 5
Inscrit le : 30 mars 2020
Version d'Excel : 2016 FR

Message par RonanE » 30 mars 2020, 15:16

Désolé...
En prenant l'exemple du mois de Mai il y a 3 opérations effectuées sur ce mois (2 négatives et 1 positive), je souhaiterais donc connaitre le taux de réussite du mois de Mai par rapport à ces résultats.

Merci !
Avatar du membre
Pedro22
Passionné d'Excel
Passionné d'Excel
Messages : 3'934
Appréciations reçues : 401
Inscrit le : 26 janvier 2017
Version d'Excel : 2010 FR
Version de Sheets : FR
Téléchargements : Mes applications

Message par Pedro22 » 30 mars 2020, 15:20

RonanE a écrit :
30 mars 2020, 15:16
Désolé...
En prenant l'exemple du mois de Mai il y a 3 opérations effectuées sur ce mois (2 négatives et 1 positive), je souhaiterais donc connaitre le taux de réussite du mois de Mai par rapport à ces résultats.

Merci !
C'est surement limpide pour vous... Mais vous ne définissez toujours pas le taux de réussite !
Ok j'ai 3 opérations : 2 négatives, 1 positive. Le taux de réussite est donc de 2/3 ?
Merci de prendre 30 sec pour lire la charte du forum.
Quelques conseils : ici
R
RonanE
Nouveau venu
Nouveau venu
Messages : 5
Inscrit le : 30 mars 2020
Version d'Excel : 2016 FR

Message par RonanE » 30 mars 2020, 15:29

Dans l'exemple c'est un peu "basique" dans le sens où il y a seulement 3 opérations pour le mois de Mai mais avec plus de données c'est forcément plus complexe.

La formule que je cherche donc à connaitre ici c'est de savoir que pour le mois de Mai j'ai 33,33% de réussite (1 résultat positif sur 3 opérations réalisées).

Dans la même logique, je suis censé obtenir 50% de réussite en Octobre (1 résultat positif sur 2 opérations dans le mois).

Est-ce plus clair ? :)
Avatar du membre
Pedro22
Passionné d'Excel
Passionné d'Excel
Messages : 3'934
Appréciations reçues : 401
Inscrit le : 26 janvier 2017
Version d'Excel : 2010 FR
Version de Sheets : FR
Téléchargements : Mes applications

Message par Pedro22 » 30 mars 2020, 15:47

RonanE a écrit :
30 mars 2020, 15:29
Est-ce plus clair ? :)
Oui !
J'ai changer vos formules dans le second tableau.

B3 : 01/01/2020 affiché au format personnalisé mmmm puis en B4 et + :
=MOIS.DECALER(B3;1)
C3 :
=NB.SI.ENS(Feuil1!$C$3:$C$12;">="&$B3;Feuil1!$C$3:$C$12;"<"&MOIS.DECALER($B3;1))
D3 :
=SIERREUR(NB.SI.ENS(Feuil1!$C$3:$C$12;">="&$B3;Feuil1!$C$3:$C$12;"<"&MOIS.DECALER($B3;1);Feuil1!$D$3:$D$12;">0")/$C3;"")
Votre fichier modifié :
Test.xlsx
(11.05 Kio) Téléchargé 2 fois
Merci de prendre 30 sec pour lire la charte du forum.
Quelques conseils : ici
Avatar du membre
Pedro22
Passionné d'Excel
Passionné d'Excel
Messages : 3'934
Appréciations reçues : 401
Inscrit le : 26 janvier 2017
Version d'Excel : 2010 FR
Version de Sheets : FR
Téléchargements : Mes applications

Message par Pedro22 » 30 mars 2020, 15:49

PS : En ajoutant une colonne binaire à votre premier tableau (1 pour positif, 0 le cas échéant), vous pouvez aussi utiliser un TCD (bien plus simple d'utilisation !) pour faire ces stats.
Il est possible de faire des taux de réussite par mois (date groupées par année + mois) en faisant la moyenne de cette nouvelle colonne (résultat à mettre au format pourcentage).

Si besoin je peux modifier votre fichier en ce sens.

:btres:
Merci de prendre 30 sec pour lire la charte du forum.
Quelques conseils : ici
R
RonanE
Nouveau venu
Nouveau venu
Messages : 5
Inscrit le : 30 mars 2020
Version d'Excel : 2016 FR

Message par RonanE » 30 mars 2020, 16:17

Tout d'abord un grand merci car mes connaissances Excel ne m'auraient jamais permis de réussir cela...
J'ai adapté votre version à mon fichier réel et ça fonctionne par contre j'avoue que j'ai essayé de déchiffrer l'ensemble et ce n'est pas simple... je suis preneur de la deuxième version pour voir si ça peut m'aider à le reproduire plus facilement sans vous solliciter à chaque fois que je bloque :)

Le problème est résolu mais avant de le fermer je veux bien la V2 qui aidera peut-être quelqu'un d'autre aussi !

Un grand merci...
Avatar du membre
Pedro22
Passionné d'Excel
Passionné d'Excel
Messages : 3'934
Appréciations reçues : 401
Inscrit le : 26 janvier 2017
Version d'Excel : 2010 FR
Version de Sheets : FR
Téléchargements : Mes applications

Message par Pedro22 » 30 mars 2020, 16:34

NB.SI.ENS() compte le nombre de lignes d'une plage qui respectent un ensemble de conditions.
Dans le cas présent, on compte le nombre de ligne comprise entre une date de début et de fin de mois.
Ensuite, on ajoute une condition supplémentaire pour les montants positifs pour la seconde formule.

Voilà la proposition avec colonne supplémentaire + TCD :
Test.xlsx
(16.02 Kio) Téléchargé 1 fois
Merci de prendre 30 sec pour lire la charte du forum.
Quelques conseils : ici
R
RonanE
Nouveau venu
Nouveau venu
Messages : 5
Inscrit le : 30 mars 2020
Version d'Excel : 2016 FR

Message par RonanE » 30 mars 2020, 16:42

Merci beaucoup !
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message