JOURSEM dans TEXTE Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
S
SHTOURS
Membre fidèle
Membre fidèle
Messages : 184
Inscrit le : 12 novembre 2018
Version d'Excel : 365

Message par SHTOURS » 25 mars 2020, 22:47

Bonjour à tous,

J'ai remarqué en utilisant la fonction JOURSEM dans un la fonction TEXTE, que celle-ci ne donne plus les mêmes résultats.

Normalement l'argument "1" devrait donner un résultat en considérant que lundi est 2eme jour de la semaine
Et l'argument "2" devrait donner un résultat en considérant que Lundi est le 1er jour de la semaine

Cependant incorporé dans la fonction TEXTE tout devient différent..

Pour obtenir un nom de jour qui correspond à celui de la colonne tout à gauche dans la feuille, il est nécessaire de spécifier à JOURSEM l'argument "1",

Avez vous une idée de l'explication à cela??

oO

Merci,
EXCEL PRATIQUE - JOURSEM - 2020 0325.xlsx
(10.06 Kio) Téléchargé 5 fois
Avatar du membre
LouReeD
Contributeur
Contributeur
Messages : 7'085
Appréciations reçues : 370
Inscrit le : 14 octobre 2014
Version d'Excel : 2013 FR, 2016 FR
Contact :
Téléchargements : Mes applications

Message par LouReeD » 25 mars 2020, 23:05

Bonsoir,

il y a confusion dans votre démarche de fonctionnement des fonctions !
Pas simple cette histoire !
Joursem(Date;0 ou 1) vous renvoie un chiffre entre 1 et 7 où 1 = dimanche
Joursem(Date;2) vous renvoie un chiffre entre 1 et 7 où 1 = lundi
etc...
Mais le retour de la fonction de joursem est bien un chiffre
donc elle renvoie 1,2,3,4,5,6 ou 7 voir 0 avec l'argument 3 par exemple.
Puis vous demandez avec TEXTE de transformer ce chiffre en jour alphanumérique avec "jjj".
Sous Excel, les dates sont égale à un chiffre entier partant de 0 à 43915 (aujourd'hui le 25/03/2020)
Du coup Texte fait son job en renvoyant le jour qui correspond par exemple au 3 janvier 1900 !

me suis-je bien fait comprendre ?

Pour faire ce que vous voulez faire essayez ceci : =TEXTE(DATE(ANNEE(B3);MOIS(B3);JOUR(B3));"jjjj")
du coup ce n'est plus un chiffre de 1 à 7 que vous transformer en lettre, mais bel et bien la valeur numérique de la date et vous tombez sur mercredi qui est bien le jour du 01/01/2020 soit le 43831 ième jour après le 01/01/1900 ! ;-)

@ bientôt

LouReeD
2 membres du forum aiment ce message.
Quelques règles à lire ICI ;;)
______________________________________________________Vous pouvez allez faire un tour sur : Index de "Mes applications" ;;)
S
SHTOURS
Membre fidèle
Membre fidèle
Messages : 184
Inscrit le : 12 novembre 2018
Version d'Excel : 365

Message par SHTOURS » 26 mars 2020, 00:53

Merci beaucoup,

j'ai tout compris :)
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message