Condition Si imbriquée ou autre condition

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Avatar du membre
Hosni
Membre dévoué
Membre dévoué
Messages : 867
Appréciations reçues : 2
Inscrit le : 24 septembre 2011
Version d'Excel : 2013/2016

Message par Hosni » 25 février 2020, 20:56

Bonjour à Tous

J'ai la formule suivante qui fonctionne parfaitement:
=SI($A$1<>"Totalité";NB.SI.ENS('Entete Devis'!B:B;">="&$A$3;'Entete Devis'!B:B;"<="&$A$4;'Entete Devis'!E:E;RGVILLE!$A$1;'Entete Devis'!G:G;RGVILLE!$A$2;'Entete Devis'!F:F;RGVILLE!$A6);NB.SI.ENS('Entete Devis'!B:B;">="&$A$3;'Entete Devis'!B:B;"<="&$A$4;'Entete Devis'!G:G;RGVILLE!$A$2;'Entete Devis'!F:F;RGVILLE!$A6))
Cette formule vérifie en A1 si le valeur est égale à "Totalité' ou bien Différente.
J'aimerai rajouter une 2eme condition en A2 qui vérifie aussi si la valeur en A2 est égale à "Totalité' ou bien Différente.

Les cas possibles sont donc:

A1 = Totalité et A2 = Totalité
A1 <> Totalité et A2 = Totalité
A1 = Totalité et A2 <> Totalité
A1 <> Totalité et A2 <> Totalité
Essai Si Imbriquée.xlsx
(359.96 Kio) Téléchargé 4 fois
Merci à tous pour votre aide.
La vie est une École, qui nous apprend tous les jours plus..., Plus on sait..., Moins on en sait...
B. Hosni
Avatar du membre
Hosni
Membre dévoué
Membre dévoué
Messages : 867
Appréciations reçues : 2
Inscrit le : 24 septembre 2011
Version d'Excel : 2013/2016

Message par Hosni » 25 février 2020, 22:27

Bonjour à tous.

J'ai mis cette formule Si(Et... pour un début elle vérifie le cas ou les deux cellules sont à Totalité,
=SI(ET($A$1<>"Totalité"$A$2<>"Totalité");
SOMME.SI.ENS(DEVIS!N:N;DEVIS!G:G;$A$1;DEVIS!Q:Q;$A$2;DEVIS!E:E;$A6;DEVIS!B:B;">="&$A$3;DEVIS!B:B;"<="&$A$4);SOMME.SI.ENS(DEVIS!N:N;DEVIS!E:E;$A6;DEVIS!B:B;">="&$A$3;DEVIS!B:B;"<="&$A$4))
Merci de vérifier et de donner un coup de main pour la suite des cas.
La vie est une École, qui nous apprend tous les jours plus..., Plus on sait..., Moins on en sait...
B. Hosni
Avatar du membre
Hosni
Membre dévoué
Membre dévoué
Messages : 867
Appréciations reçues : 2
Inscrit le : 24 septembre 2011
Version d'Excel : 2013/2016

Message par Hosni » 25 février 2020, 23:08

Bonsoir

Encore un test avec Si Imbriqué,
=SI($A$1<>"Totalité";SI($A$2<>"Totalité" ;SOMME.SI.ENS(DEVIS!N:N;DEVIS!G:G;$A$1;DEVIS!Q:Q;$A$2;DEVIS!E:E;$A6;DEVIS!B:B;">="&$A$3;DEVIS!B:B;"<="&$A$4);SOMME.SI.ENS(DEVIS!N:N;DEVIS!E:E;$A6;DEVIS!B:B;">="&$A$3;DEVIS!B:B;"<="&$A$4;DEVIS!G:G;$A$1);SOMME.SI.ENS(DEVIS!N:N;DEVIS!G:G;$A$1;DEVIS!Q:Q;$A$2;DEVIS!E:E;$A6;DEVIS!B:B;">="&$A$3;DEVIS!B:B;"<="&$A$4))
Y aurait-il quelqu'un pour me donner conseil ou éventuellement me corriger ???

Merci
La vie est une École, qui nous apprend tous les jours plus..., Plus on sait..., Moins on en sait...
B. Hosni
Avatar du membre
Zebulon2
Membre fidèle
Membre fidèle
Messages : 353
Appréciations reçues : 29
Inscrit le : 6 juillet 2019
Version d'Excel : Office 2019 FR

Message par Zebulon2 » 26 février 2020, 01:38

Bonsoir Hosni,

Une proposition, à toi de remplacer les conditions par les formules adéquates, cela devrait fonctionner.


=SI(ET($A$1="Totalité";$A$2="Totalité");
A1 = Totalité et A2 = Totalité;
SI(ET($A$1<>"Totalité";$A$2="Totalité");
A1 <> Totalité et A2 = Totalité;
SI(ET($A$1="Totalité";$A$2<>"Totalité");
A1 = Totalité et A2 <>Totalité;
A1 <> Totalité et A2 <>Totalité)))

Cordialement.
Essai Si Imbriquée.xlsx
(361.53 Kio) Téléchargé 2 fois
Avatar du membre
Hosni
Membre dévoué
Membre dévoué
Messages : 867
Appréciations reçues : 2
Inscrit le : 24 septembre 2011
Version d'Excel : 2013/2016

Message par Hosni » 26 février 2020, 08:24

Bonjour Zebulon2 , à tous

Merci pour votre réponse, je vais adapter et je reviens vers vous durant la journée au plus tard cet après midi.

Cordialement
La vie est une École, qui nous apprend tous les jours plus..., Plus on sait..., Moins on en sait...
B. Hosni
Avatar du membre
Hosni
Membre dévoué
Membre dévoué
Messages : 867
Appréciations reçues : 2
Inscrit le : 24 septembre 2011
Version d'Excel : 2013/2016

Message par Hosni » 26 février 2020, 08:50

Bonjour!

Je reviens plus tôt que prévu et je relance cette formule:
=SI($A$1<>"Totalité";
SI($A$2<>"Totalité";
SOMME.SI.ENS(DEVIS!N:N;DEVIS!G:G;$A$1;DEVIS!Q:Q;$A$2;DEVIS!E:E;$A6;DEVIS!B:B;">="&$A$3;DEVIS!B:B;"<="&$A$4);
SOMME.SI.ENS(DEVIS!N:N;DEVIS!E:E;$A6;DEVIS!B:B;">="&$A$3;DEVIS!B:B;"<="&$A$4;DEVIS!G:G;$A$1));

SOMME.SI.ENS(DEVIS!N:N;DEVIS!G:G;$A$1;DEVIS!Q:Q;$A$2;DEVIS!E:E;$A6;DEVIS!B:B;">="&$A$3;DEVIS!B:B;"<="&$A$4))
Merci à vous de me corriger, quand j'ai mis cette formule sur le classeur elle ne donne aucun résultat et pourtant elle parait juste.

Cordialement
La vie est une École, qui nous apprend tous les jours plus..., Plus on sait..., Moins on en sait...
B. Hosni
Avatar du membre
Zebulon2
Membre fidèle
Membre fidèle
Messages : 353
Appréciations reçues : 29
Inscrit le : 6 juillet 2019
Version d'Excel : Office 2019 FR

Message par Zebulon2 » 26 février 2020, 12:35

Bonjour,

Peux tu mettre la formule pour chaque cas de figure :

A1 = Totalité et A2 = Totalité formule
A1 <> Totalité et A2 = Totalité formule
A1 = Totalité et A2 <> Totalité formule
A1 <> Totalité et A2 <> Totalité formule

Cordialement.
Avatar du membre
Hosni
Membre dévoué
Membre dévoué
Messages : 867
Appréciations reçues : 2
Inscrit le : 24 septembre 2011
Version d'Excel : 2013/2016

Message par Hosni » 27 février 2020, 07:10

Bonjour

Merci encore pour votre réponse.
Ce que je veux c'est une seule formule qui résume le tout.
J'ai essayer de mettre la formule, je penses que c'est un problème de logique qui reste à résoudre.

Pouvez vous essayer encore.

Merci à vous et bonne journée.
La vie est une École, qui nous apprend tous les jours plus..., Plus on sait..., Moins on en sait...
B. Hosni
Avatar du membre
Zebulon2
Membre fidèle
Membre fidèle
Messages : 353
Appréciations reçues : 29
Inscrit le : 6 juillet 2019
Version d'Excel : Office 2019 FR

Message par Zebulon2 » 27 février 2020, 12:20

Bonjour,
Ce que je veux c'est une seule formule qui résume le tout.
Ok, je veux bien, mais quel est la réponse à ma question ?
Il y a 4 possibilités et trois réponses (ou plus).


Possibilités :
A1 = Totalité et A2 = Totalité
A1 <> Totalité et A2 = Totalité
A1 = Totalité et A2 <> Totalité
A1 <> Totalité et A2 <> Totalité

Réponses :
SOMME.SI.ENS(DEVIS!N:N;DEVIS!G:G;$A$1;DEVIS!Q:Q;$A$2;DEVIS!E:E;$A6;DEVIS!B:B;">="&$A$3;DEVIS!B:B;"<="&$A$4)
SOMME.SI.ENS(DEVIS!N:N;DEVIS!E:E;$A6;DEVIS!B:B;">="&$A$3;DEVIS!B:B;"<="&$A$4;DEVIS!G:G;$A$1))
SOMME.SI.ENS(DEVIS!N:N;DEVIS!G:G;$A$1;DEVIS!Q:Q;$A$2;DEVIS!E:E;$A6;DEVIS!B:B;">="&$A$3;DEVIS!B:B;"<="&$A$4)

Pour chaque possibilités, quel est la réponse ?
Cordialement.
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message