Compatibilité formule Google Sheets/Excel Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
D
David2b
Jeune membre
Jeune membre
Messages : 39
Appréciations reçues : 3
Inscrit le : 14 décembre 2018
Version d'Excel : 2013

Message par David2b » 31 janvier 2020, 10:34

Bonjour,
Je viens vous demander de l'aide car je ne comprend pas pourquoi le même fichier me donne des résultats différent si je l'ouvre dans google sheets ou dans excel. Apparemment cela serait du à la formule "ARRAY_CONSTRAIN" (c'est en anglais car je l'ai eu par un anglais). A savoir que les résultats correct sont ceux présent dans le tableur google, j'aimerai donc avoir les mêmes résultats dans le fichier excel.
Je vous met en lien le fichier google sheets et le fichier excel pour que vous puissiez jeter un coup d'oeil, merci :)

lien google sheets : https://docs.google.com/spreadsheets/d/ ... edit#gid=0
StressIndexPlanner (RTS Classroom).xlsx
(10.54 Kio) Téléchargé 6 fois
D
David2b
Jeune membre
Jeune membre
Messages : 39
Appréciations reçues : 3
Inscrit le : 14 décembre 2018
Version d'Excel : 2013

Message par David2b » 31 janvier 2020, 12:10

En fait, il s'avère que le problème soit liée aux coefficients présent dans la formule "SOMME.SERIES", quand je modifie manuellement les "1.1.1.1.1 etc.." ça fonctionne, en gros il faut que lorsqu'une valeur est présente dans la colonne "Reps" le coefficient soit modifier en fonction de cette valeur. Je donne un exemple pour que vous compreniez mieux :
Si dans la colonne "Reps" la valeur est de 10 alors le coefficient doit être modifier en "1.1.1.1.1.1.1.1.1.1" (il y'a autant de "1" que de reps soit 10 fois "1"), je sais pas si je me suis bien expliquer auquel cas posez moi vos questions :) Merci
D
David2b
Jeune membre
Jeune membre
Messages : 39
Appréciations reçues : 3
Inscrit le : 14 décembre 2018
Version d'Excel : 2013

Message par David2b » 1 février 2020, 18:04

je relance pour savoir si quelqu'un a une solution, merci :)
Avatar du membre
eriiic
Passionné d'Excel
Passionné d'Excel
Messages : 9'709
Appréciations reçues : 446
Inscrit le : 7 février 2010
Version d'Excel : 2010fr

Message par eriiic » 2 février 2020, 00:05

Bonjour,

en fait tu veux une matrice de 1 de x lignes sur 1 colonne.
Remplacer :
ARRAY_CONSTRAIN({1;1;1;1;1;1;1;1;1;1;1;1;1;1;1};1;A3)
par :
DECALER($ZZ$1;;;A3)+1
J'ai pris ZZ1 suffisamment loin pour avoir des cellules vides (0+1=1).

Ce qui donne en C3 :
=SI(ET(1<=A3;A3<=15;5<=B3;B3<=10;(A3+(10-B3))<=15);SOMME.SERIES(EXP(1);-0.215*(A3+(10-B3)-1);0.215;DECALER($ZZ$1;;;A3)+1)*DECALER(CustomRPECharts!B$3;0;A3*2-2+(10-B3)*2)/260*1.4;"")
matricielle.
eric
1 membre du forum aime ce message.
En essayant continuellement, on finit par réussir.
Donc plus ça rate, plus on a de chances que ça marche.
(les Shadoks)

En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
D
David2b
Jeune membre
Jeune membre
Messages : 39
Appréciations reçues : 3
Inscrit le : 14 décembre 2018
Version d'Excel : 2013

Message par David2b » 2 février 2020, 12:05

Super, après quelques test ça marche, merci beaucoup j'en voyais plus la sortie :lol:
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message