RechercheV

Y compris Power BI, Power Query et toute autre question en lien avec Excel
M
Marie.h3
Jeune membre
Jeune membre
Messages : 49
Inscrit le : 25 mars 2016
Version d'Excel : 2013

Message par Marie.h3 » 17 janvier 2020, 16:43

Bonjour à tous,

Tout d'abord, tous mes meilleurs voeux pour cette nouvelle année

Ma formule ne fonctionne pas =RECHERCHEV(C2;Feuil2!A1:D79;2;FAUX)

Je vous joins un exemple de mon fichier en pièce jointe.

Merci d'avance pour votre aide

Marie
RechercheVerreur.xlsx
(13.63 Kio) Téléchargé 6 fois
Avatar du membre
Arnaud87
Jeune membre
Jeune membre
Messages : 45
Inscrit le : 8 mai 2019
Version d'Excel : 2016 FR

Message par Arnaud87 » 17 janvier 2020, 16:49

Bonjour Marie.h3

Meilleur vœux à toi aussi.

Pour que ta formule fonctionne il faut que la table matrice commence par ta colonne de la valeur recherché soit pour ta recherche la colonne B.

Ta formule devrait etre donc =RECHERCHEV(C2;Feuil2!B2:D79;2;FAUX)

Cordialement Arnaud
M
Marie.h3
Jeune membre
Jeune membre
Messages : 49
Inscrit le : 25 mars 2016
Version d'Excel : 2013

Message par Marie.h3 » 17 janvier 2020, 16:58

Bonjour Arnaud et merci ça fonctionne
Petite question pourquoi je dois commencer en B2
Le but de la rechercheV ce n'est pas de rechercher n'importent quelle colonne du tableau
Cdlt
Marie
Avatar du membre
Jean-Eric
Fanatique d'Excel
Fanatique d'Excel
Messages : 16'182
Appréciations reçues : 635
Inscrit le : 27 août 2012
Version d'Excel : 365 Personnel

Message par Jean-Eric » 17 janvier 2020, 17:12

Bonjour,
Une autre solution avec INDEX+EQUIV.
Cdlt.
RechercheVerreur.xlsx
(11.68 Kio) Téléchargé 13 fois
Jean-Eric

Je ne réponds pas aux M.P. non sollicités.
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message
  • Recherchev
    par letranquille » 3 novembre 2019, 21:14 » dans Excel - VBA
    1 Réponses
    60 Vues
    Dernier message par Yvouille
    3 novembre 2019, 21:40
  • RechercheV
    par boby83 » 9 janvier 2016, 09:34 » dans Excel - VBA
    3 Réponses
    179 Vues
    Dernier message par Jean-Eric
    9 janvier 2016, 11:36
  • RechercheV
    par neoss » 24 août 2016, 11:39 » dans Excel - VBA
    2 Réponses
    84 Vues
    Dernier message par neoss
    24 août 2016, 11:57
  • RECHERCHEV
    par FRED_22 » 3 janvier 2017, 15:04 » dans Excel - VBA
    3 Réponses
    45 Vues
    Dernier message par Steelson
    3 janvier 2017, 17:07
  • Recherchev
    par tauru » 21 février 2018, 20:26 » dans Excel - VBA
    18 Réponses
    607 Vues
    Dernier message par tauru
    26 février 2018, 21:48
  • RechercheV et #NA
    par pepericou » 21 février 2018, 17:26 » dans Excel - VBA
    8 Réponses
    192 Vues
    Dernier message par pepericou
    22 février 2018, 16:11