Affichage colonne 2 à partir d'une partie du texte de la colonne 1

Y compris Power BI, Power Query et toute autre question en lien avec Excel
C
CyCell
Nouveau venu
Nouveau venu
Messages : 8
Inscrit le : 24 décembre 2014
Version d'Excel : 2010 FR

Message par CyCell » 16 janvier 2020, 17:10

Bonjour,

J'ai plusieurs feuilles dans mon fichier.
Dans la première feuille, j'ai deux colonnes.
Dans ma deuxième feuilles le texte de la première colonne est pratiquement identique à la première feuille.
Et je veux récupérer la deuxième colonne en fonction d'une partie du texte de la première colonne.
Par exemple :
1 ère feuille 1 ère colonne : blabla = 125/300
1 ère feuille 2 ème colonne : tatatiti
2 ème feuille 1 ère colonne : blabla = 50/150
Je veux donc afficher dans la 2 ème colonne tatatiti.
J'ai utilisé la formule suivante :
=RECHERCHEV((GAUCHE(A4;NBCAR(A4)-10));APR!$A$3:$B$89;2;0)
mais en retour j'ai #N/A.
La formule =GAUCHE(A4;NBCAR(A4)-10) seule me renvoie bien la partie du texte.
Si quelqu'un pouvait m'aider, merci d'avance.

Cy
Avatar du membre
Pedro22
Passionné d'Excel
Passionné d'Excel
Messages : 3'730
Appréciations reçues : 375
Inscrit le : 26 janvier 2017
Version d'Excel : 2010 FR
Version de Sheets : FR
Téléchargements : Mes applications

Message par Pedro22 » 16 janvier 2020, 17:13

Bonjour,

Pour pouvoir apporter une aide pertinente, il faudrait commencer par fournir un fichier avec des exemples exhaustifs...
Merci de prendre 30 sec pour lire la charte du forum.
Quelques conseils : ici
C
CyCell
Nouveau venu
Nouveau venu
Messages : 8
Inscrit le : 24 décembre 2014
Version d'Excel : 2010 FR

Message par CyCell » 17 janvier 2020, 08:51

Bonjour,

J'ai ajouté un fichier exemple qui j'espère vous permettra de mieux comprendre ma demande.
Merci.
Exemple.xlsx
(10.87 Kio) Téléchargé 2 fois
Avatar du membre
Pedro22
Passionné d'Excel
Passionné d'Excel
Messages : 3'730
Appréciations reçues : 375
Inscrit le : 26 janvier 2017
Version d'Excel : 2010 FR
Version de Sheets : FR
Téléchargements : Mes applications

Message par Pedro22 » 17 janvier 2020, 09:03

Bonjour,

Même en isolant la partie commune de l'un des 2 éléments, il ne correspond toujours pas à son homologue qui comporte encore une partie unique. En l'état, une formule RECHERCHEV ne pourra donc pas fonctionner.

J'ai en tête 2 possibilités :
1. Utiliser l'outil "Convertir" (menu "Données") pour séparer la colonne contenant le texte (sur chacune des 2 feuilles) en 2 colonnes distinctes, selon le signe "=" (qui semble être un dénominateur commun entre toutes les lignes).
Ceci permet ensuite une recherche "classique" sur la partie fixe et commune aux 2 feuilles.

2. Isoler le nombre à gauche du texte, qui correspond à priori à un identifiant unique, permettant donc de faire une recherche.
Une piste en formule =
=GAUCHE(A1;TROUVE(" ";A1))*1
Modifié en dernier par Pedro22 le 17 janvier 2020, 12:16, modifié 2 fois.
Merci de prendre 30 sec pour lire la charte du forum.
Quelques conseils : ici
C
CyCell
Nouveau venu
Nouveau venu
Messages : 8
Inscrit le : 24 décembre 2014
Version d'Excel : 2010 FR

Message par CyCell » 17 janvier 2020, 12:11

Merci pour les conseils :-)
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message