Faire correspondre des données dans excel Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Avatar du membre
laurentzic
Jeune membre
Jeune membre
Messages : 42
Appréciation reçue : 1
Inscrit le : 28 mai 2016
Version d'Excel : 2013 fr
Contact :

Message par laurentzic » 6 janvier 2020, 16:50

Bonjour,

Je ne sais pas si je suis dans le bon forum car je ne parle pas de VBA ici mais de formule excel.

Comme vous pourrez le voir dans le tableau joint, chaque employé est relié à un service d'attache (=un magasin) qui est référencé par un no. Le but de générer un tel rapport est de pouvoir faire des suivi sur les employés étant toujours à l'embauche, ou ayant visionné certaines capsules de formation en ligne ou encore ayant passé les questionnaires obligatoires etc...
Les codes de magasins ne changent donc pas, les employés si.

J'ai mis dans un onglet les codes associés au service d'attache. Mais le must serait évidemment de faire aller chercher la base de donnée dans un fichier différent qui ne bougera pas, car faire du copier coller à chaque rapport c'est pas très productif.

Lorsque je génère un rapport qui me donne le fichier excel, les nom des magasins ne figure évidemment pas, juste les codes.
Mon souhait serait donc de faire en sorte d'associer les codes des magasins (par rapport à la liste du premier onglet), et de les insérer dans la colonne suivantes aux codes par exemple.

J'ai utilisé la fonction RECHERCHEV mais ça ne fonctionne pas, car quand je colle la formule dans la premiere cellule de la colonne qui suit les codes, cela me donne une erreur.
La difficulté réside également dans le fait que je ne saisis pas les codes, car il le sont déjà.

Pouvez-vous m'aider?

Voici le fichier :
RAPPORT_RÉGULIER-2020-01-06.xlsx
(206.68 Kio) Téléchargé 4 fois
Merci d'avance et bonne journée à tous


Laurent
Avatar du membre
OOoiste
Membre impliqué
Membre impliqué
Messages : 1'605
Appréciations reçues : 22
Inscrit le : 1 octobre 2009
Version d'Excel : office 365

Message par OOoiste » 6 janvier 2020, 17:08

Bonjour,

Le problème vient du fait que les codes dans le rapport sont des valeurs numériques alors qu'elles sont en "texte" dans la base.

Pour contourner le problème il suffit de concaténer le nombre avec une chaine de texte nulle .
G2 → G2&""
=RECHERCHEV(G2&"";Données!$A$2:$B$67;2;FAUX)
A+
Avatar du membre
laurentzic
Jeune membre
Jeune membre
Messages : 42
Appréciation reçue : 1
Inscrit le : 28 mai 2016
Version d'Excel : 2013 fr
Contact :

Message par laurentzic » 6 janvier 2020, 18:24

Merci ça fonctionne effectivement mieux en concaténant.

Merci beaucoup :)
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message