Somme.si plage contient deux lettres Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
Avatar du membre
Nathalie Charette
Membre habitué
Membre habitué
Messages : 111
Appréciations reçues : 5
Inscrit le : 13 mai 2014
Version d'Excel : 2010FR
Contact :

Message par Nathalie Charette » 21 novembre 2019, 11:12

Rebonjour !

J'ai une autre petite préoccupation.
Dans une plage j'ai des villes et dans l'autre des valeurs comme ci-dessous:
Alabama;50
Ambam;12
Kaélé;8
Mboy;15
Bertoua;20
Loum;5
Je solliciterais avec la fonction SOMMES.SI sommer les villes contenant un a et un b, d'une part, et celles contenant a ou b d'autre part.

J'ai essayé les symboles mais on dirait que quelque chose m'échappe quant à leur implémentation.

Merci !
Je peux facilement faire l'idiot quand je suis intello, mais pas le contraire ! :wink:
Avatar du membre
Yvouille
Passionné d'Excel
Passionné d'Excel
Messages : 9'137
Appréciations reçues : 94
Inscrit le : 6 avril 2007
Version d'Excel : 2016

Message par Yvouille » 21 novembre 2019, 11:35

Salut Nathalie,

Peux-tu préciser si tu souhaites effectuer la somme des villes dont la première lettre est un a ou un b OU des villes qui contiennent un a ou un b n'importe où dans leur nom ?

Cordialement.
Yvouille

Valais de Coeur
Avatar du membre
Nathalie Charette
Membre habitué
Membre habitué
Messages : 111
Appréciations reçues : 5
Inscrit le : 13 mai 2014
Version d'Excel : 2010FR
Contact :

Message par Nathalie Charette » 21 novembre 2019, 12:41

Yvouille a écrit :
21 novembre 2019, 11:35
Salut Nathalie,

Peux-tu préciser si tu souhaites effectuer la somme des villes dont la première lettre est un a ou un b OU des villes qui contiennent un a ou un b n'importe où dans leur nom ?

Cordialement.
soit un A ou un B n'importe où dans ce nom ou un A et un B n'importe ou dans ce nom.

Merci !
Je peux facilement faire l'idiot quand je suis intello, mais pas le contraire ! :wink:
F
Fatos
Membre habitué
Membre habitué
Messages : 88
Appréciations reçues : 13
Inscrit le : 17 octobre 2010
Version d'Excel : 2010 FR

Message par Fatos » 21 novembre 2019, 16:20

Bonjour,

Ci-joint, une proposition utilisant des colonnes intermédiaires.

Je ne doute pas que d'autres propositions viendront, et seront plus "compactes" :wink:

À vous lire,
Contient.xlsx
(8.89 Kio) Téléchargé 7 fois
1 membre du forum aime ce message.
Avatar du membre
xorsankukai
Membre impliqué
Membre impliqué
Messages : 2'327
Appréciations reçues : 263
Inscrit le : 7 octobre 2014
Version d'Excel : 2010 FR

Message par xorsankukai » 21 novembre 2019, 17:51

Bonsoir tout le monde, (°v°)°

Un essai..... :lole:
  • a où b :
    =SOMME.SI.ENS(C3:C8;B3:B8;"*a*";B3:B8;"<>"&"*b*")+SOMME.SI.ENS(C3:C8;B3:B8;"<>"&"*a*";B3:B8;"*b*")
  • a & b :
    =SOMME.SI.ENS(C3:C8;B3:B8;"*a*";B3:B8;"*b*")
Contient-2.xlsx
(9.09 Kio) Téléchargé 4 fois
Cordialement,
1 membre du forum aime ce message.
xorsankukai

La connaissance, c’est partager le savoir qui nous fait grandir.
Avatar du membre
Nathalie Charette
Membre habitué
Membre habitué
Messages : 111
Appréciations reçues : 5
Inscrit le : 13 mai 2014
Version d'Excel : 2010FR
Contact :

Message par Nathalie Charette » 25 novembre 2019, 09:29

Merci à tous, ca m'arrange !
Je peux facilement faire l'idiot quand je suis intello, mais pas le contraire ! :wink:
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message