Liste de personnes disponibles sur un periode

Y compris Power BI, Power Query et toute autre question en lien avec Excel
M
Morgans
Nouveau venu
Nouveau venu
Messages : 1
Inscrit le : 5 novembre 2019

Message par Morgans » 5 novembre 2019, 15:30

Bonjour,

Je travaille en tant que chargé de recrutement dans une agence d'intérim et je souhaiterais me faire un fichier (sur Excel 2007) afin de me faciliter la vie mais je n'y arrive pas et j'aurais besoin de vos lumières.
Voici ma problématique :
Je souhaiterais quand une entreprise m'appelle en me disant "on aurait besoin d'une personne pour telle période" (ça peut être 1 jour comme ça peut être 4 mois ou plus) pouvoir dans mon fichier Excel renseigner les dates de début et de fin du besoin et obtenir une liste (et le nombre) des intérimaires disponibles (ni en mission, ni en congé, ni en arrêt) sur cette période. Et en bonus pouvoir cliquer sur le nom d'un intérimaire de cette liste et obtenir directement les infos principales sur l'intérimaire (numéro de téléphone, adresse postale, adresse mail, etc...).
Suis je obligé de passer par une macro (sachant que je ne maîtrise pas trop) ? Un Userform ? Est ce que des tableaux croisés dynamiques suffiraient ? (sachant que j'ai déjà fait pas mal d'essais et je n'arrive pas a obtenir ce que je veux).

En pièce jointe un exemple de planning intérimaire (sachant que je suis ouvert à toute propositions de modifications du planning)

Merci d'avance pour votre aide.

Cordialement

Morgan.
Interime.xlsx
(44.36 Kio) Téléchargé 5 fois
G
Girodo
Membre dévoué
Membre dévoué
Messages : 578
Appréciations reçues : 29
Inscrit le : 24 mars 2015
Version d'Excel : 2010

Message par Girodo » 5 novembre 2019, 16:04

Salut,

En bricolant tu peux y arriver par formule...

(Il faut cliquer sur réappliquer dans Données/filtres à chaque changement de date pour que tout se mette à jour)

Girodo,
Interime.xlsx
(55.51 Kio) Téléchargé 4 fois
Petit Chêne deviendra gland ! :btres:
n
njhub
Membre impliqué
Membre impliqué
Messages : 1'214
Appréciations reçues : 63
Inscrit le : 5 juin 2017
Version de Calc : 6.2.8.2 FR-YT

Message par njhub » 5 novembre 2019, 16:17

Bonjour, Morgans, Girodo, le forum

Voyez si le fichier joint peut vous aider,
Pour l'utilisation, changez les dates en B2 et B3 de la feuille "Besoin",
remplacer les données par les valeurs réelles.
=SI($A6="";"";INDIRECT("Feuil2!C"&EQUIV($B6;$Feuil2.$B$3:$B$102;0);1))
Morgan_Interim.xlsx
(43.18 Kio) Téléchargé 3 fois
Avatar du membre
eriiic
Passionné d'Excel
Passionné d'Excel
Messages : 9'150
Appréciations reçues : 351
Inscrit le : 7 février 2010
Version d'Excel : 2010fr

Message par eriiic » 5 novembre 2019, 16:40

Bonjour,

une autre façon
=SI(NBVAL(DECALER($A13;;EQUIV($B$6;$9:$9;0)-1;;$B$7-$B$6+1))=0;"dispo";"")
eric
Interime.xlsx
(46.91 Kio) Téléchargé 2 fois
En essayant continuellement, on finit par réussir.
Donc plus ça rate, plus on a de chances que ça marche.
(les Shadoks)

En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message