Fonction décaler avec INDEX et EQUIV et plusieurs variables Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
M
Miniteca
Jeune membre
Jeune membre
Messages : 18
Inscrit le : 8 avril 2019
Version d'Excel : 2016 FR

Message par Miniteca » 4 novembre 2019, 15:11

Bonjour,

Je dois, via INDEX EQUIV retrouver le NOM du technicien associé à 2 variables (SPECIFICITE et Agence).

J'utilise la formule suivante sans soucis:

{=INDEX(NOM;EQUIV('ANNUAIRE EXPERTS'!B5&'ANNUAIRE EXPERTS'!D5;SPECIFICITE&Agence;0);0)}

En B5 j'ai un menu déroulant avec la spécificité recherchée et en D5 j'ai un menu avec l'agence (menus déroulants avec fonction INDIRECT pour aller chercher dans ma base).

Seul problème, dans certains cas je peux avoir 2 techniciens répondant aux mêmes requêtes et donc je dois DECALER ma formule pour trouver le deuxième. J'avoue que je m'y perd un peu.

J'ai écris cette formule mais Excel ne veut pas me la prendre:
{=index(decaler(NOM;equiv($B$5&$D$5;SPECIFICITE&Agence;0);0);equiv($B$5&$D$5;decaler(SPECIFICITE&Agence;equiv($B$5&$D$5;SPECIFICITE&Agence;0);0);0);0)}

Je n'arrive pas à voir d'où vient mon problème (j'ai les yeux qui se croisent à force de chercher)...
M
Miniteca
Jeune membre
Jeune membre
Messages : 18
Inscrit le : 8 avril 2019
Version d'Excel : 2016 FR

Message par Miniteca » 4 novembre 2019, 15:18

En PJ mon fichier avec en E6 le NOM du deuxième technicien...
ANNUAIRE EXPERTS.xlsx
Mon fichier
(17.93 Kio) Téléchargé 8 fois
m
m3ellem1
Membre impliqué
Membre impliqué
Messages : 1'892
Appréciations reçues : 167
Inscrit le : 18 décembre 2018
Version d'Excel : 2016

Message par m3ellem1 » 4 novembre 2019, 17:16

Salut Miniteca,

formule matricielle (Ctrl+Maj+Entrée) à insérer dans E1 de la feuille ANNUAIRE EXPRESS et tu tires vers le bas
=SI(LIGNE(Z1)>SOMME((SPECIFICITE=$B$5)*(Agence=$D$5));"";INDEX(NOM;PETITE.VALEUR(SI((SPECIFICITE=$B$5)*(Agence=$D$5);LIGNE($1:$45));LIGNE(Z1))))
À partir d'hier, j'ai décidé de ne plus expliquer les solutions proposées et de ne plus répondre aux MP!
M
Miniteca
Jeune membre
Jeune membre
Messages : 18
Inscrit le : 8 avril 2019
Version d'Excel : 2016 FR

Message par Miniteca » 4 novembre 2019, 17:53

m3ellem1 a écrit :
4 novembre 2019, 17:16
Salut Miniteca,

formule matricielle (Ctrl+Maj+Entrée) à insérer dans E1 de la feuille ANNUAIRE EXPRESS et tu tires vers le bas
=SI(LIGNE(Z1)>SOMME((SPECIFICITE=$B$5)*(Agence=$D$5));"";INDEX(NOM;PETITE.VALEUR(SI((SPECIFICITE=$B$5)*(Agence=$D$5);LIGNE($1:$45));LIGNE(Z1))))
Ne fonctionne pas et oui, elle est bien validée en matricielle...
m
m3ellem1
Membre impliqué
Membre impliqué
Messages : 1'892
Appréciations reçues : 167
Inscrit le : 18 décembre 2018
Version d'Excel : 2016

Message par m3ellem1 » 4 novembre 2019, 18:27

c'est ton excel qui fonctionne pas correctement pas la formule :mrgreen:

au plaisir
ANNUAIRE EXPERTS-1_1.xlsx
(17.99 Kio) Téléchargé 8 fois
1 membre du forum aime ce message.
À partir d'hier, j'ai décidé de ne plus expliquer les solutions proposées et de ne plus répondre aux MP!
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'789
Appréciations reçues : 262
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 4 novembre 2019, 19:21

bonjour
une contribution sans validation
miniteca.xlsx
(23.57 Kio) Téléchargé 7 fois
cordialement
c'est en cherchant qu'on trouve
M
Miniteca
Jeune membre
Jeune membre
Messages : 18
Inscrit le : 8 avril 2019
Version d'Excel : 2016 FR

Message par Miniteca » 5 novembre 2019, 08:54

m3ellem1 a écrit :
4 novembre 2019, 18:27
c'est ton excel qui fonctionne pas correctement pas la formule :mrgreen:

au plaisir

ANNUAIRE EXPERTS-1_1.xlsx
Merci. Effectivement cela fonctionne...comprends pas pourquoi avec moi non...
M
Miniteca
Jeune membre
Jeune membre
Messages : 18
Inscrit le : 8 avril 2019
Version d'Excel : 2016 FR

Message par Miniteca » 6 novembre 2019, 11:30

Bonjour,

J'ai de nouveau un soucis sur mon fichier et je n'arrive pas à comprendre d'où il vient.

J'ai inséré dans l'onglet base des lignes pour enrichir la liste de mes experts et leur spécialité.

Quand je sélectionne SSI avec Extension_modification_installation et l'agence MMT, aucun nom ne remonte et j'ai un #N/A à la place...

J'avoue ne pas comprendre et avoir besoin d'aide.
ANNUAIRE EXPERTS.xlsx
(20.86 Kio) Téléchargé 1 fois
m
m3ellem1
Membre impliqué
Membre impliqué
Messages : 1'892
Appréciations reçues : 167
Inscrit le : 18 décembre 2018
Version d'Excel : 2016

Message par m3ellem1 » 6 novembre 2019, 12:11

Salut,

à tester
ANNUAIRE EXPERTS_1.xlsx
(21.01 Kio) Téléchargé 5 fois
P.S. la procheine fois il faut ouvrir un nouveau sujet ;;)
1 membre du forum aime ce message.
À partir d'hier, j'ai décidé de ne plus expliquer les solutions proposées et de ne plus répondre aux MP!
M
Miniteca
Jeune membre
Jeune membre
Messages : 18
Inscrit le : 8 avril 2019
Version d'Excel : 2016 FR

Message par Miniteca » 6 novembre 2019, 13:01

Merci ça à l'air de fonctionner correctement.
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message