Validation de données

Bonsoir,

J'ai une liste à partir de la cellule B3 (j'irai jusqu’à 50000) et une rechercheV en D4 (j'irai jusqu’à 50000). Actuellement, lorsque je choisis le A11 , il retourne bien son équivalent en D3 mais une fois. En B10 il ne donne plus sont équivalent en D10.

Dans le liste le A12 et d'autre ne répond même pas de leur équivalent.

Puis-je avoir votre aide, SVP

Merci

2essai-1.xlsx (12.31 Ko)

Bonsoir,

Ta formule RECHERCHEV n'est pas correcte au 2ème paramètre(la plage de recherche) à partir de la cellule D4.

Constate-la dans D3 et D4, ce paramètre change or il faut que la plage de recherche reste identique partout.

Essaye comme ça dans la cellule D3 et copie-la vers le bas :

=SIERREUR(RECHERCHEV(B3;App!$A$1:$B$61;2;FALSE);"")

Cela ne fonctionne toujours pas, je mets un nouveau fichier avec chaque formule pour la visibilité.

Le A11 et A12 tjrs abs

Merci

Au cas => Je suis avec office 2016 64 bits sous W10 pro.

1essai-1.xlsx (12.78 Ko)

j'ai compris le pourquoi, il faut incrémenter que la cellule de la liste dans la formule.

Je joint le fichier.

Par contre comment faire car je me vois pas modifier les 50000 lignes.

Merci

2essai-1.xlsx (13.58 Ko)

Salut Eworks, Slt le Forum

ou bien en tirant la formule de Raja vers le bas tout en respectant les $ !!!!!!!!!!

=SIERREUR(RECHERCHEV(B3;App!$A$1:$B$50000;2;FALSE);"")

ou bien essaie cete macro

Sub inserer_formule()
Dim sht As Worksheet
Set sht = Worksheets("Index")

    With sht
        .Range("D3").FormulaR1C1 = "=IFERROR(VLOOKUP(RC[-2],App!R1C1:R61C2,2,FALSE),"""")"
        .Range("D3").Copy
        .Range("D4:D50000").PasteSpecial (xlPasteAll)
    End With
End Sub

Bonsoir a vous,

Je vous remercie de votre coup de main. Cela fonctionne très bien.

Rechercher des sujets similaires à "validation donnees"