Pb extraction date chaîne de caractère Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
e
edlede
Membre dévoué
Membre dévoué
Messages : 710
Appréciations reçues : 6
Inscrit le : 4 novembre 2015
Version d'Excel : 2013

Message par edlede » 17 octobre 2019, 11:45

Bonjour le forum

Je fasse à un probleme que je n'arrive pas à contourner facilement,

Voilà dans ma colonne A j'ai une chaine de caratere qui contient presque toujours une date, et toujours au meme endroit qd elle est présente.

En utilisant des formules du type
= droite(A2;nb)
j'arrive a obtenir une valeur du type 03/09/2019
Mais impossible de la faire reconnaître comme une date.

et régulièrement j'ai une cellule qui ne contient pas de date. et dans ce cas là j'aimerai pouvoir inscrire la valeur de la cellule précédente.

J'avais utilisé
=SI(ESTNUM(B2);B2;B1)
mais comme ma date n'est pas reconnue même en forçant le format, la formule ne me sert à rien.

J'ai essayé en vba mais j'ai fais choux blanc.

Si vous avez une piste
Excel pratique_pb extraction date.xlsx
(10.39 Kio) Téléchargé 4 fois
h
h2so4
Passionné d'Excel
Passionné d'Excel
Messages : 9'154
Appréciations reçues : 376
Inscrit le : 16 juin 2013
Version d'Excel : 365 UK Windows 10

Message par h2so4 » 17 octobre 2019, 12:05

Bonjour,

essaie ceci
=SIERREUR(DATEVAL(STXT(A1;9;10));A1)
Avatar du membre
Steelson
Fanatique d'Excel
Fanatique d'Excel
Messages : 14'029
Appréciations reçues : 830
Inscrit le : 13 octobre 2014
Version d'Excel : 2013 FR
Téléchargements : Mes applications

Message par Steelson » 17 octobre 2019, 12:07

Bonjour,

essaie
= cnum(droite(A2;nb))
maintenant, tes données sont un peu plus complexes que cela

edit : désolé h2so4, je n'avais pas vu ta réponse

O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸ O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸
PI = 3.14159 26535 89793 23846 26433 83279 50288 41971 69399 37510 58209 74944 59230 78164 06286 20899 86280

( ͡• ͜ʖ ͡• )
h
h2so4
Passionné d'Excel
Passionné d'Excel
Messages : 9'154
Appréciations reçues : 376
Inscrit le : 16 juin 2013
Version d'Excel : 365 UK Windows 10

Message par h2so4 » 17 octobre 2019, 12:23

bonjour Steelson,
edit : désolé h2so4, je n'avais pas vu ta réponse
toujours heureux de découvrir d'autres réponses possibles. Pas de problème, donc !
e
edlede
Membre dévoué
Membre dévoué
Messages : 710
Appréciations reçues : 6
Inscrit le : 4 novembre 2015
Version d'Excel : 2013

Message par edlede » 17 octobre 2019, 12:28

Merci à vous deux pour vos reponses!

H2SO4 c'est parfait,
[Edit formule]
Il possible de combiner ta formule avec celle ci =SI(ESTNUM(B2);B2;C1), ???

Sinon je garde deux colonnes ca change pas grand chose!

Parfait je valide
h
h2so4
Passionné d'Excel
Passionné d'Excel
Messages : 9'154
Appréciations reçues : 376
Inscrit le : 16 juin 2013
Version d'Excel : 365 UK Windows 10

Message par h2so4 » 17 octobre 2019, 13:05

bonjour,
Il possible de combiner ta formule avec celle ci =SI(ESTNUM(B2);B2;C1), ???
oui tu peux imbriquer des SI,

remplace par exemple le dernier A1 par ta formule (sans le signe =)
=SIERREUR(DATEVAL(STXT(A1;9;10));A1)
par
=SIERREUR(DATEVAL(STXT(A1;9;10));SI(ESTNUM(B2);B2;C1))
à adapter selon ce que tu veux faire (ordre et références aux cellules). Je n'ai pas assez d'info pour te donner la formule que tu souhaites.
e
edlede
Membre dévoué
Membre dévoué
Messages : 710
Appréciations reçues : 6
Inscrit le : 4 novembre 2015
Version d'Excel : 2013

Message par edlede » 17 octobre 2019, 13:30

Merci H2SO4,

Ta reponse me semble logique mais j'ai qd même un bug, dans l'exemple je devrai avoir dans la ligne 4 et 5 la date du 04/09/2019

Et j ai la date du 03 :cry: par defaut je comprend pas pourquoi alors qu'en deux colnne jai le bon resultat.
Excel pratique_pb extraction date2.xlsx
(9.47 Kio) Téléchargé 2 fois
h
h2so4
Passionné d'Excel
Passionné d'Excel
Messages : 9'154
Appréciations reçues : 376
Inscrit le : 16 juin 2013
Version d'Excel : 365 UK Windows 10

Message par h2so4 » 17 octobre 2019, 14:48

bonjour,

pas sûr d'avoir compris ce que tu cherches à faire, mais voici ...
Excel pratique_pb extraction date2.xlsx
(9.12 Kio) Téléchargé 1 fois
e
edlede
Membre dévoué
Membre dévoué
Messages : 710
Appréciations reçues : 6
Inscrit le : 4 novembre 2015
Version d'Excel : 2013

Message par edlede » 17 octobre 2019, 15:10

Purée, plus c'est simple moins je le vois !
je cherches toujours midi à 14h !!
C'est parfait,

Voilà le resultat !

Image
Annotation 2019-10-17 150932.jpg
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message