Formule Montant selon valeur Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Avatar du membre
BernardDRANEB
Jeune membre
Jeune membre
Messages : 24
Inscrit le : 21 août 2019
Version d'Excel : 2010

Message par BernardDRANEB » 20 septembre 2019, 11:51

Bonjour,
Petite question toute bête sûrement.
J'ai 3 colonnes une avec un montant, une avec un résultat et une avec un montant à M+1
Si j'ai KO en C2, la formule rentrée en D2 doit pouvoir doubler le montant en A2.
=SI C2=0;"";(C2="KO";A2*2)
L'idée étant bien sûr de pouvoir l'appliquer à toute ma colonne sans avoir de valeur = FAUX sur les lignes vides avec seulement =SI(C2="KO";A2*2)
Merci d'avance.
m
melch
Membre dévoué
Membre dévoué
Messages : 592
Appréciations reçues : 27
Inscrit le : 28 juillet 2016
Version d'Excel : 2007 FR, 2013 FR

Message par melch » 20 septembre 2019, 11:53

Bonjour,

la fonction te renvoie FAUX car tu ne précise pas ce qu'elle doit renvoyer si c'est faux. il faut rajouter du coup le "sinon" de ta fonction "si" :
=SI(C2="KO";A2*2;"")
Avatar du membre
BernardDRANEB
Jeune membre
Jeune membre
Messages : 24
Inscrit le : 21 août 2019
Version d'Excel : 2010

Message par BernardDRANEB » 20 septembre 2019, 11:58

Quelle nouille, je suis... effectivement ma formule n'était pas bien rédigée...
Quitte à être une nouille autant être un beau cannelloni: et mettons qu'il y ait également la condition du si OK;"" ? Parce que là du coup, je ne vois pas. Autant je comprenais mettre planter dans ma première question autant là, avec une autre condition, je sèche.
m
melch
Membre dévoué
Membre dévoué
Messages : 592
Appréciations reçues : 27
Inscrit le : 28 juillet 2016
Version d'Excel : 2007 FR, 2013 FR

Message par melch » 20 septembre 2019, 12:00

ReBonjour :

Alors dans ce cas, il faut deux "si" imbriqués :
=SI(C2="ok";A2;SI(C2="ko";A2*2;""))
Là, si c'est "ok" alors on reprends A2, sinon si c'est "ko" alors on reprends A2*2, sinon, on reprends rien ("")
Avatar du membre
BernardDRANEB
Jeune membre
Jeune membre
Messages : 24
Inscrit le : 21 août 2019
Version d'Excel : 2010

Message par BernardDRANEB » 20 septembre 2019, 12:06

Super, c'est bien ça, j'ai ajusté selon le résultat que je souhaite avoir si OK:
=SI(C2="ok";"";SI(C2="ko";A2*2;""))
Merci et bon weekend !
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message