Pb syntaxe RechercheV Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
V
Valo
Jeune membre
Jeune membre
Messages : 24
Appréciation reçue : 1
Inscrit le : 14 février 2016
Version d'Excel : 2007

Message par Valo » 28 juillet 2019, 11:01

Bonjour le forum
La formule ci dessous me permet de mettre la date en clair exemple Mardi et elle fonctionne
en C7 =TEXTE(DATE($E$4; RECHERCHEV($D$4;$AI$1:$AJ$12;2;0);1);"jjjj")
avec comme critére en AI les Mois et en AJ Les Nombres 1 à 12. sur la même feuille.

En rajoutant une feuille "Param" pour dissocier les paramétres et les données
creitere en A2 les Mois et B2 les Nombre
la nouvelle formule ne fonctionne pas
=TEXTE(DATE($E$3; RECHERCHEV($D$3;Param!$A$2:$B$13;2;0);1);"jjjj")
je pense à un pb de syntaxe, merci d'avance pour m' aider à la corriger
En piéce jointe un exemple
Cordialement
exemple.xls
(30 Kio) Téléchargé 6 fois
Avatar du membre
mdo100
Membre dévoué
Membre dévoué
Messages : 931
Appréciations reçues : 39
Inscrit le : 25 mai 2013
Version d'Excel : 2010 FR

Message par mdo100 » 28 juillet 2019, 11:36

Bonjour Valo, le forum,

A tester en "C6"
=TEXTE(DATE($E$3; RECHERCHEV($D$3;Pram!$A$2:$B$13;2;0);B6);"jjjj")
Tirer vers le bas autant que nécessaire.

Cordialement.
Avatar du membre
lauange
Membre fidèle
Membre fidèle
Messages : 235
Appréciation reçue : 1
Inscrit le : 2 février 2016
Version d'Excel : 2013FR

Message par lauange » 28 juillet 2019, 11:38

Salut,

L'erreur doit être sur le nom de ton onglet, car dans ta formule il s'appelle param et dans ton classeur pram.
Excel 2013 windows et Excel 2016 Mac OSX
Avatar du membre
Jean-Eric
Fanatique d'Excel
Fanatique d'Excel
Messages : 16'718
Appréciations reçues : 703
Inscrit le : 27 août 2012
Version d'Excel : 365 Personnel

Message par Jean-Eric » 28 juillet 2019, 23:12

Bonjour,
Une autre proposition.
Cdlt.
exemple.xls
(39.5 Kio) Téléchargé 3 fois
Jean-Eric

Je ne réponds pas aux M.P. non sollicités.
V
Valo
Jeune membre
Jeune membre
Messages : 24
Appréciation reçue : 1
Inscrit le : 14 février 2016
Version d'Excel : 2007

Message par Valo » 29 juillet 2019, 19:48

Bonjour le forum
Merci à tous pour vos réponses, je vais faire les tests et ferai un retour
Cordialement
V
Valo
Jeune membre
Jeune membre
Messages : 24
Appréciation reçue : 1
Inscrit le : 14 février 2016
Version d'Excel : 2007

Message par Valo » 31 juillet 2019, 07:06

Bonjour le forum
Merci à tous les corrections ont été faites et ca fonctione
Cordialement
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message
  • Probleme de syntaxe rechercheV
    par damien14 » 26 juin 2019, 11:06 » dans Excel - VBA
    7 Réponses
    277 Vues
    Dernier message par damien14
    26 juin 2019, 12:15
  • Syntaxe rechercheV dans un autre classeur, erreur 9
    par louisP » 24 mars 2015, 16:41 » dans Excel - VBA
    3 Réponses
    433 Vues
    Dernier message par gmb
    26 mars 2015, 11:40
  • syntaxe
    par Civo » 3 avril 2017, 19:37 » dans Excel - VBA
    17 Réponses
    283 Vues
    Dernier message par MFerrand
    9 avril 2017, 12:37
  • Syntaxe
    par Civo » 12 octobre 2015, 10:57 » dans Excel - VBA
    6 Réponses
    179 Vues
    Dernier message par Civo
    12 octobre 2015, 13:02
  • Syntaxe NB.SI
    par Robinet » 8 mai 2020, 15:55 » dans Excel - VBA
    1 Réponses
    23 Vues
    Dernier message par BrunoM45
    8 mai 2020, 17:42
  • Syntaxe
    par Civo » 1 décembre 2014, 11:33 » dans Excel - VBA
    3 Réponses
    216 Vues
    Dernier message par James007
    1 décembre 2014, 16:00