Total Distinct (formule LIREDONNEES) Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
W
Willou
Membre habitué
Membre habitué
Messages : 143
Inscrit le : 16 août 2018
Version d'Excel : 2016

Message par Willou » 5 juillet 2019, 14:21

Bonjour,

Je cherche à customiser cette formule qui est un simple égal vers un TCD (PowerPivot) comme j'avais besoin de "Total Distinct".
J'ai besoin de modifier le 100Mega en la cellule C16.
J'ai beau trafiquer la forumule j'ai #Ref.
Une idée ?

Merci

=LIREDONNEESTABCROISDYNAMIQUE("[Measures].[Somme de Extended Price (USD)2 2]";'Global Pivot'!$L$108;"[Plage1].[Reseller Country]";"[Plage1].[Reseller Country].&[Poland]";"[Plage1].[Partner Name]";"[Plage1].[Partner Name].&[100MEGA]";"[Plage1].[Fiscal Year]";"[Plage1].[Fiscal Year].&[2019]")
Avatar du membre
Xmenpl
Membre impliqué
Membre impliqué
Messages : 2'213
Appréciations reçues : 145
Inscrit le : 16 mai 2018
Version d'Excel : 2003 à 2013

Message par Xmenpl » 5 juillet 2019, 14:50

Bonjour,
Sans fichier difficile de voir à quoi correspond 100MEGA ? un nom ce cellule ? une fonction ? .....
W
Willou
Membre habitué
Membre habitué
Messages : 143
Inscrit le : 16 août 2018
Version d'Excel : 2016

Message par Willou » 5 juillet 2019, 14:55

Bonjour,

C'est juste le nom d'un revendeur.
Mais comme je joue avec le TCD ce revendeur change et je souhaite qu'il aille chercher la cellule C16 plutôt pour ce filtre.

Mon fichier est très lourd et ne passe pas sur le forum.
Avatar du membre
Xmenpl
Membre impliqué
Membre impliqué
Messages : 2'213
Appréciations reçues : 145
Inscrit le : 16 mai 2018
Version d'Excel : 2003 à 2013

Message par Xmenpl » 5 juillet 2019, 15:36

Tu as tapé manuellement C16 ou tu as selectionné la cellule C16 ?
effaces [100MEGA] et selectionnes la cellule C16
W
Willou
Membre habitué
Membre habitué
Messages : 143
Inscrit le : 16 août 2018
Version d'Excel : 2016

Message par Willou » 5 juillet 2019, 15:46

Oui je crois bien. Je vous ai mis un exemple.
Comment insérer B1 à la place de AST Market dans la formule?
Merci
Exemple.xlsx
(286.48 Kio) Téléchargé 2 fois
Avatar du membre
Xmenpl
Membre impliqué
Membre impliqué
Messages : 2'213
Appréciations reçues : 145
Inscrit le : 16 mai 2018
Version d'Excel : 2003 à 2013

Message par Xmenpl » 5 juillet 2019, 16:04

Willou a écrit :
5 juillet 2019, 15:46
Oui je crois bien. Je vous ai mis un exemple.
Comment insérer B1 à la place de AST Market dans la formule?
Merci

Exemple.xlsx
La formule sert à à trouver la correspondance de AST Market dans la colonne suivante ::o ?

dans ce cas autant écrire : en C1 = =RECHERCHEV(B1;B7:F27;2;FAUX)
W
Willou
Membre habitué
Membre habitué
Messages : 143
Inscrit le : 16 août 2018
Version d'Excel : 2016

Message par Willou » 5 juillet 2019, 16:45

C'est un exemple. Le TCD bougera.
Avatar du membre
Xmenpl
Membre impliqué
Membre impliqué
Messages : 2'213
Appréciations reçues : 145
Inscrit le : 16 mai 2018
Version d'Excel : 2003 à 2013

Message par Xmenpl » 5 juillet 2019, 16:53

Willou a écrit :
5 juillet 2019, 16:45
C'est un exemple. Le TCD bougera.
çà change quoi ?
même si il fait 900 lignes au lieu de 27 lignes au départ le principe est le même ! le nom recherché n'apparaitra qu'une fois et
le résultat souhaité sera bien dans la colonne d'à coté non ?

il suffit de prévoir une plage de recherche plus grande =RECHERCHEV(B1;B7:F9000;2;FAUX)
Avatar du membre
78chris
Passionné d'Excel
Passionné d'Excel
Messages : 4'311
Appréciations reçues : 319
Inscrit le : 9 juillet 2017
Version d'Excel : 2010 à 2019 + 365

Message par 78chris » 5 juillet 2019, 16:56

Bonjour à tous

Remplacer [100MEGA] par "]" & C16 & "]"
=LIREDONNEESTABCROISDYNAMIQUE("[Measures].[Somme de Extended Price (USD)2 2]";'Global Pivot'!$L$108;"[Plage1].[Reseller Country]";"[Plage1].[Reseller Country].&[Poland]";"[Plage1].[Partner Name]";"[Plage1].[Partner Name].&[" & C16 & "]";"[Plage1].[Fiscal Year]";"[Plage1].[Fiscal Year].&[2019]")
Il est préférable à mon humbe avis d'utiliser LIREDONNEESTABCROISDYNAMIQUE pour exploiter les TCD
Chris
Quand un homme a faim, mieux vaut lui apprendre à pêcher que de lui donner un poisson.
Confucius
W
Willou
Membre habitué
Membre habitué
Messages : 143
Inscrit le : 16 août 2018
Version d'Excel : 2016

Message par Willou » 5 juillet 2019, 18:12

La recherche V n'est pas possible car parfois je peux ne pas avoir de données en 2019 donc je risquerais d'avoir des données de 2020 apparaitre en 2019
Donc il faut que je fasse LIREDONNEESTABCROISDYNAMIQUE
@78chris j'ai toujours #Ref :cry:
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message