Compter le nombre de a dans plusieurs cellules Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
A
Aelig
Jeune membre
Jeune membre
Messages : 21
Inscrit le : 15 février 2013
Version d'Excel : 2010

Message par Aelig » 12 mai 2019, 20:10

Bonjour,

Je veux compter le nombre total de a qui se trouve dans les cellules E3, F3 et G3.
J'ai essayé la formule suivante mais sans succès =SI(ESTERREUR(CHERCHE("a";(E3:G3)));1;0).
Merci pur votre aide

Aelig
b
boss_68
Membre fidèle
Membre fidèle
Messages : 222
Appréciations reçues : 18
Inscrit le : 17 décembre 2018
Version d'Excel : 2003

Message par boss_68 » 12 mai 2019, 20:34

Bonjour

Peut-être comme ça

=NB.SI(E3:G3;"a")

Slt
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'669
Appréciations reçues : 237
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 12 mai 2019, 20:45

bonjour
=SOMME(SI(ESTNUM(CHERCHE("a";STXT(E3:G3;LIGNE(1:100);1)));1;""))
matricielle à valider avec les touches Ctrl Maj Entrée en simultané
cordialement
c'est en cherchant qu'on trouve
Avatar du membre
James007
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'007
Appréciations reçues : 421
Inscrit le : 30 août 2014
Version d'Excel : 2007 EN

Message par James007 » 12 mai 2019, 20:53

Bonjour à tous ...

Salut Tulipe ... :wink:

Une variante ... pour ne pas se faire de contorsions des doigts ...
=SOMMEPROD(NBCAR(E3:G3)-NBCAR(SUBSTITUE(E3:G3;"a";"")))
En espèrant que cela t'aide
A+

:)

Quand on n’a qu’un marteau, tous les problèmes deviennent des clous…
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'669
Appréciations reçues : 237
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 12 mai 2019, 21:18

James007 a écrit :
12 mai 2019, 20:53
Bonjour à tous ...

Salut Tulipe ... :wink:

Une variante ... pour ne pas se faire de contorsions des doigts ...
=SOMMEPROD(NBCAR(E3:G3)-NBCAR(SUBSTITUE(E3:G3;"a";"")))
En espèrant que cela t'aide
en effet ;c'est très malin 8-)
c'est en cherchant qu'on trouve
A
Aelig
Jeune membre
Jeune membre
Messages : 21
Inscrit le : 15 février 2013
Version d'Excel : 2010

Message par Aelig » 12 mai 2019, 21:20

Merci à tous les 3,
j'ai testé la solution la plus simple, celle de boss et ça marche au poil.
Avatar du membre
James007
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'007
Appréciations reçues : 421
Inscrit le : 30 août 2014
Version d'Excel : 2007 EN

Message par James007 » 13 mai 2019, 06:45

Bonjour à tous,
tulipe_4 a écrit :
12 mai 2019, 21:18
en effet ; c'est très malin 8-)
Merci Tulipe ;;)

Note aux futurs lecteurs : ... Tulipe et moi avons compris qu'il fallait :

" Compter le nombre de plusieurs a dans plusieurs cellules " ...
A+

:)

Quand on n’a qu’un marteau, tous les problèmes deviennent des clous…
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'669
Appréciations reçues : 237
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 13 mai 2019, 11:35

bonjour
au cazou le "a" n'est pas au debut
NB.SI(D2;">a")
par exemple
cordialement
c'est en cherchant qu'on trouve
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message